 <!DOCTYPE html> <html lang="en" xmlns="http://www.w3.org/1999/xhtml"> <head> <title>5 Things to Watch for at Microsoft Build 2017</title> <link rel="canonical" href="http://www.cmswire.com/information-management/5-things-to-watch-for-at-microsoft-build-2017/" /> <meta name="news_keywords" content="ecm,sharepoint,office,information management,eim,office 365,cortana,bots"> <script> var contentAuthor = 'David Roe';
        var contentPublishDate = '2017-05-09';
        var contentTemplate = 'article';
        var contentItemId = '{EB047E0B-62F7-49F0-BD14-9AB6548CAD61}'; </script> <meta name="description" content="The Microsoft Build conference heads north this year, moving from its San Francisco base to kick off tomorrow in Seattle.&amp;nbsp; The three-day conference will give developers a chance to catch up on th" /> <meta name="twitter:card" content="summary_large_image" /> <meta name="twitter:image" content="http://www.cmswire.com/~/media/d7b6e6356cb34fdf8ca523367ac9434e.jpg" /> <meta property="og:image" content="http://www.cmswire.com/~/media/d7b6e6356cb34fdf8ca523367ac9434e.jpg" /> <meta name="twitter:site" content="@CMSWire" /> <meta name="twitter:creator" content="@druadh20" /> <meta name="twitter:url" content="http://www.cmswire.com/information-management/5-things-to-watch-for-at-microsoft-build-2017/" /> <meta name="twitter:title" content="5 Things to Watch for at Microsoft Build 2017" /> <meta name="twitter:description" content="The Microsoft Build conference heads north this year, moving from its San Francisco base to kick off tomorrow in Seattle.&amp;nbsp; The three-day conference will give developers a chance to catch up on th" /> <meta name="og:description" value="The Microsoft Build conference heads north this year, moving from its San Francisco base to kick off tomorrow in Seattle.&amp;nbsp; The three-day conference will give developers a chance to catch up on th" /> <meta property="og:type" content="article" /> <meta property="article:publisher" content="https://www.facebook.com/CMSWire" /> <script type="application/ld+json"> {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "headline": "5 Things to Watch for at Microsoft Build 2017",
        "url": "http://www.cmswire.com/information-management/5-things-to-watch-for-at-microsoft-build-2017/",
            "thumbnailUrl": "http://www.cmswire.com/~/media/d7b6e6356cb34fdf8ca523367ac9434e.jpg",
                    "dateCreated": "2017-05-09T18:45:50",        "articleSection": "Information Management",
        "creator": "David Roe",
        "keywords": ["ecm", "sharepoint", "microsoft", "office", "information management", "eim", "office 365", "cortana", "bots", "build 2017", "category: information management", "type: news", "utype: staff"],
        "metadata": {"type": "news", "category" : "information management", "sophistication" : "general"}
        } </script> <link rel="shortcut icon" href="/~/media/0f48619f063d48bfa500ab082f28eda7.png" type="image/x-icon" /><script type="text/javascript" src="//use.typekit.net/gtl4etw.js"></script> <script type="text/javascript">try{Typekit.load();}catch(e){}</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info = {"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"5205defa29","applicationID":"13012606","transactionName":"YwRVMUJZDBYEW0RRVlpOejNzFzEMEV1TV0tRIlgLREoNCQldQhdwWgVSHQ==","queueTime":0,"applicationTime":884,"ttGuid":"95DF76A3A36CA6FF","agent":""}</script><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,n,t){function r(t){if(!n[t]){var o=n[t]={exports:{}};e[t][0].call(o.exports,function(n){var o=e[t][1][n];return r(o||n)},o,o.exports)}return n[t].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<t.length;o++)r(t[o]);return r}({1:[function(e,n,t){function r(){}function o(e,n,t){return function(){return i(e,[c.now()].concat(u(arguments)),n?null:this,t),n?void 0:this}}var i=e("handle"),a=e(2),u=e(3),f=e("ee").get("tracer"),c=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,n){s[n]=o(d+n,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),n.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,n){var t={},r=this,o="function"==typeof n;return i(l+"tracer",[c.now(),e,t],r),function(){if(f.emit((o?"":"no-")+"fn-start",[c.now(),r,o],t),o)try{return n.apply(this,arguments)}finally{f.emit("fn-end",[c.now()],t)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,n){m[n]=o(l+n)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,c.now()])}},{}],2:[function(e,n,t){function r(e,n){var t=[],r="",i=0;for(r in e)o.call(e,r)&&(t[i]=n(r,e[r]),i+=1);return t}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],3:[function(e,n,t){function r(e,n,t){n||(n=0),"undefined"==typeof t&&(t=e?e.length:0);for(var r=-1,o=t-n||0,i=Array(o<0?0:o);++r<o;)i[r]=e[n+r];return i}n.exports=r},{}],4:[function(e,n,t){n.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,n,t){function r(){}function o(e){function n(e){return e&&e instanceof r?e:e?f(e,u,i):i()}function t(t,r,o,i){if(!d.aborted||i){e&&e(t,r,o);for(var a=n(o),u=m(t),f=u.length,c=0;c<f;c++)u[c].apply(a,r);var p=s[y[t]];return p&&p.push([b,t,r,a]),a}}function l(e,n){v[e]=m(e).concat(n)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(t)}function g(e,n){c(e,function(e,t){n=n||"feature",y[t]=n,n in s||(s[n]=[])})}var v={},y={},b={on:l,emit:t,get:w,listeners:m,context:n,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",f=e("gos"),c=e(2),s={},p={},d=n.exports=o();d.backlog=s},{}],gos:[function(e,n,t){function r(e,n,t){if(o.call(e,n))return e[n];var r=t();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,n,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[n]=r,r}var o=Object.prototype.hasOwnProperty;n.exports=r},{}],handle:[function(e,n,t){function r(e,n,t,r){o.buffer([e],r),o.emit(e,n,t)}var o=e("ee").get("handle");n.exports=r,r.ee=o},{}],id:[function(e,n,t){function r(e){var n=typeof e;return!e||"object"!==n&&"function"!==n?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");n.exports=r},{}],loader:[function(e,n,t){function r(){if(!x++){var e=h.info=NREUM.info,n=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&n))return s.abort();c(y,function(n,t){e[n]||(e[n]=t)}),f("mark",["onload",a()+h.offset],null,"api");var t=d.createElement("script");t.src="https://"+e.agent,n.parentNode.insertBefore(t,n)}}function o(){"complete"===d.readyState&&i()}function i(){f("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),f=e("handle"),c=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1026.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=n.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),f("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script> <meta name="viewport" content="width=device-width, initial-scale=1"> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script>  <link href='/content/public/css-core.css?v=21633266' rel="stylesheet" type="text/css" /> <link href='/content/public/css-supporting.css?v=21633266' rel="stylesheet" type="text/css" /> <script src="/bundles/public/coveo-dependencies.js?v=21633266" type="text/javascript"></script> <script src="/bundles/public/jquery-features.js?v=21633266" type="text/javascript"></script> <script src="/bundles/public/js-supporting.js?v=21633266" type="text/javascript"></script> <script> //Global vars
var oEmailSubTimer; var dvEmailSub, dvEventSubmit, dvOssSurvey; var visitCount=0; var emailVisitCount=0;
var $jQ = jQuery.noConflict();
$ = jQuery.noConflict(); </script> <script> var isMobile = window.matchMedia("only screen and (max-width: 760px)").matches; </script> <script> var isTablet = window.matchMedia("only screen and (max-width: 1200px)").matches; </script><script type="text/javascript"> (function() {
		var css = document.createElement('link');
		css.href = '//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.1.0/css/font-awesome.min.css';
		css.rel = 'stylesheet';
		css.type = 'text/css';
		document.getElementsByTagName('head')[0].appendChild(css);
	})(); </script><script> var isMobile = window.matchMedia("only screen and (max-width: 760px)").matches; </script> <meta name="verify-v1" content="HdocqHqkIh/dBv6gbC1hYzp8AZFAws0DzzDbycC/O88=" /> <script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script> <script type="text/javascript"> var _gaq = _gaq || [];
var _authorName = (typeof(contentAuthor) != "undefined") ? contentAuthor : "System";
var _publishDate = (typeof(contentPublishDate) != "undefined") ? contentPublishDate: "2015-04-01";
var _contentTemplate = (typeof(contentTemplate) != "undefined") ? contentTemplate: "Undefined";
_gaq.push(['_setAccount', 'UA-202362-1']);
_gaq.push(['_setDomainName', 'cmswire.com']);
_gaq.push(['_setAllowLinker', true]);
_gaq.push(['_setCustomVar', 1, 'AuthorName', _authorName, 3]);
_gaq.push(['_setCustomVar', 2, 'PublishDate', _publishDate, 3]);
_gaq.push(['_trackPageview']);
_gaq.push(['_trackEvent', 'PageViewByAuthor', _authorName, location.pathname]);
_gaq.push(['_trackEvent', 'PageViewByType', _contentTemplate, location.pathname]);

(function() {
	var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
	ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
	var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
})(); </script>  <script type="text/javascript"> var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
   var gads = document.createElement("script");
   gads.async = true;
   gads.type = "text/javascript";
   var useSSL = "https:" == document.location.protocol;
   gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
   var node =document.getElementsByTagName("script")[0];
   node.parentNode.insertBefore(gads, node);
  })();
	
googletag.cmd.push(function() {
  consoleMsg('DFP - Command queue processing is starting...');
  googletag.pubads().addEventListener('slotRenderEnded', function(event) {
          var $slotName = event.slot.getAdUnitPath();
	  consoleMsg('DFP - Slot: ' +$slotName +' with ID: \'' + event.slot.getSlotElementId() +'\' rendered. Setting CSS.');
          updateDFPSlots();
  });
});
function updateDFPSlots() {
  $jQ("iframe[id*='google_ads_iframe_']").not('[id*=__hidden__]').each(function(key,val) {
    var $slotName = $jQ(this).attr('name');
    var $cssHref = window.location.protocol +'//' +window.location.hostname + $jQ('link[href*=css-core]').attr('href');
    var $head = $jQ(this).contents().find("head");
    if($head.find('link').length < 1) { 
      consoleMsg('DFP - Post processing slot: ' +$slotName);
      $head.append($jQ("<link/>", {rel: "stylesheet",href: $cssHref,type: "text/css" }));
      $jQ(this).contents().find("a").attr("target","_blank");  
      if($slotName.indexOf('Homepage-Top_468x15') > 0 || $slotName.indexOf('Article-Top_468x15') > 0) {
        //$jQ(this).css({'width':'100%','height':'18px'});
        //$jQ(this).contents().find("a").css({'font-size': '15px','font-weight':'300', 'display': 'block', 'color':'red', 'font-family':'museo-sans,sans-serif','text-decoration':'none'}); //#f76600
      } else if($slotName.indexOf('Article-Base_600x200') > 0) {
        $jQ(this).css({'width':'100%'});
      }
    }
    //resizeIframe(this);
  });
}
function resizeIframe(obj) {
  obj.style.height = 0;
  obj.style.height = obj.contentWindow.document.body.scrollHeight + 'px';
}
$jQ(document).ready(function() { setTimeout(function(){ updateDFPSlots(); }, 1300); });
$jQ(document).ready(function() { setTimeout(function(){ updateDFPSlots(); }, 3000); }); </script> <script type="text/javascript"> function setCookieLocal(n,v,xdays) {
  var exdate=new Date();
  exdate.setDate(exdate.getDate() + xdays);
  var val=escape(v) + ((xdays==null) ? "" : ("; expires="+exdate.toUTCString()));
  document.cookie= n + "=" + val + "; path=/";
}
function getCookieLocal(name) {
  var value = "; " + document.cookie;
  var parts = value.split("; " + name + "=");
  if (parts.length == 2) {return parts.pop().split(";").shift();}
  else {return -1;}
}
var iVisitCount = getCookieLocal('VisitCount');
var iEmailVisitCount = getCookieLocal('EmailVisitCount');
var bEmailSubscribed = getCookieLocal('Newsletter_Subscribed') != -1 ? true : false;
var iLastNLPop = getCookieLocal('LastNLPop');

if(bEmailSubscribed == false && iEmailVisitCount > 0) {bEmailSubscribed = true;}
else if (window.location.href.indexOf('mkt_tok') > -1) {bEmailSubscribed = true;}
else if (document.referrer.indexOf('go.simplermedia.com') > -1) {bEmailSubscribed = true;}
var bDoNLPop = bEmailSubscribed == false && (iLastNLPop < 0 || Math.floor(Date.now() / 1000) - iLastNLPop > (60*60*48));
try {console.log('Email Subscribed: ' + bEmailSubscribed +'. Last NLPop: ' +iLastNLPop +'. DoNLPop: ' +bDoNLPop);} catch(e) {}

//NL Prompt
function showNewsletterPrompt(delaySecs, dfpClick, v) {
  if(bEmailSubscribed == false && bDoNLPop) {
    setCookieLocal('LastNLPop', Math.floor(Date.now() / 1000), 5);
    cwc_showNewsletterDialog(delaySecs,dfpClick, v);
    _gaq.push(['_trackEvent', 'NL-Prompt', 'Display', v]);		
  }
}
jQuery(document).ready(function() {
  var pVer = '03a';
  //Disabled on 08-Jun-2016 -Fred Flinny
  //showNewsletterPrompt(0,'',pVer); 
  //jQuery('#nlp' +pVer +'_txtEmail').focus();
});

//DFP
googletag.cmd.push(function() { googletag.pubads().setTargeting('page_url', window.location.pathname.replace(new RegExp('/', 'g'), '_')); });
try {console.log('page_url: ' + window.location.pathname.replace(new RegExp('/', 'g'), '_'));} catch(e) {}
// New visitor?
if (iVisitCount > 0) { googletag.cmd.push(function() { googletag.pubads().setTargeting('NewVisitor', 'false'); }); } else { googletag.cmd.push(function() {googletag.pubads().setTargeting('NewVisitor', 'true'); }); }
// Email subscriber?
if(bEmailSubscribed) { googletag.cmd.push(function() { googletag.pubads().setTargeting('SubEmail', 'true'); }); } else { googletag.cmd.push(function() { googletag.pubads().setTargeting('SubEmail', 'false'); }); } </script><script type="text/javascript"> var disqus_domain = 'disqus.com';
var disqus_shortname = 'cmswire'; </script><link rel="alternate" type="application/rss+xml" title="CMSWire - All News" href="http://feeds2.feedburner.com/CMSWire" /> <link rel="alternate" type="application/rss+xml" title="CMSWire - Upcoming Events" href="http://feeds2.feedburner.com/CMSWire-Events" /> <link rel="me" type="text/html" href="https://plus.google.com/+CMSWire" /> <link rel="me" type="text/html" href="https://twitter.com/CMSWire" /> <script type='text/javascript'> (function(c,h,a,f,i,e){c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
 c[a].a=i;c[a].e=e;var g=h.createElement("script");g.async=true;g.type="text/javascript";
 g.src=f+'?aid='+i;var b=h.getElementsByTagName("script")[0];b.parentNode.insertBefore(g,b);
 })(window,document,"rtp","//sjrtp4-cdn.marketo.com/rtp-api/v1/rtp.js","simplermediagroup");
 
rtp('send','view');
rtp('get', 'campaign',true); </script> <script src="//load.sumome.com/" data-sumo-site-id="8be930c765939695646a5aef3ca375134ac2e81704447f5f11b50cc837554e16" async="async"></script><script> !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1754830201503161'); // Insert your pixel ID here.
fbq('track', 'PageView'); </script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1754830201503161&ev=PageView&noscript=1"
/></noscript>  <link href='/public/common/dynamic.css?ids=450f2610-b62c-4c8b-a924-0764a0212363' rel="stylesheet" type="text/css" /> <script type="text/javascript"> googletag.cmd.push(function () {
googletag.defineSlot('/1003060/Popup-Poll', [420, 540], 'div-gpt-ad-1336852434508-6').addService(googletag.pubads());
googletag.defineSlot('/1003060/Inline-300x250--01', [300, 250], 'div-gpt-ad-1336852434508-3').addService(googletag.pubads());
googletag.defineSlot('/1003060/CW_JS-01', [10, 10], 'div-gpt-ad-1352353012906-0').addService(googletag.pubads());
googletag.defineSlot('/1003060/Article-Top_468x15', [468, 15], 'div-gpt-ad-1336852434508-2').addService(googletag.pubads());
googletag.defineSlot('/1003060/Article-Base_600x200', [600, 200], 'div-gpt-ad-1336852434508-1').addService(googletag.pubads());
googletag.defineSlot('/1003060/Article-Base_300x250', [300, 250], 'div-gpt-ad-1336852434508-0').addService(googletag.pubads());

if (typeof(isMobile) == "undefined" || isMobile === false) {
googletag.defineSlot('/1003060/Sitewide-Top_728', [728, 90], 'div-gpt-ad-1336852434508-10').addService(googletag.pubads());
}

if (typeof(isTablet) == "undefined" || isTablet === false) {
googletag.defineSlot('/1003060/Side-Right_300x600', [300, 600], 'div-gpt-ad-1336852434508-8').addService(googletag.pubads());
}

googletag.pubads().collapseEmptyDivs();

googletag.pubads().enableSingleRequest();

googletag.pubads().setTargeting("tags", ["ecm","sharepoint","microsoft","office","information_management","eim","office_365","cortana","bots","build_2017"]);
            googletag.enableServices();
        }); </script>  <link rel="schema.dcterms" href="http://purl.org/dc/terms/"> <meta name="dcterms.language" content="en-us" /> <meta name="dcterms.format" content="text/html" /> <meta name="dcterms.publisher" content="Simpler Media Group, Inc." /> <meta name="dcterms.rights" content="Copyright 2003-2017 Simpler Media Group, Inc." />  <meta property='fb:app_id' content='131721606912999' /> <meta property="og:site_name" content="CMSWire.com" /> <meta property="og:title" content="5 Things to Watch for at Microsoft Build 2017" /> <meta property="og:language" content="en-US" /> <meta property="og:country-name" content="USA" /> <link rel="start" href="http://www.cmswire.com/" title="Home" /> <script> jQuery(document).ready(function () {
            consoleMsg('Site root: http://www.cmswire.com/ ');
            consoleMsg('Template: article ');
            //fix according  feature/OT-1376-Update_Auto_Redirect_to_Homepage_to_a_Page_Refresh
            setRF();
        }); </script> </head> <body class="article">  <div id="parsely-root" style="display: none"> <div id="parsely-cfg" data-parsely-site="cmswire.com"></div> </div> <script> (function(s, p, d) { 
  var h=d.location.protocol, i=p+"-"+s, 
      e=d.getElementById(i), r=d.getElementById(p+"-root"), 
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net" 
      :"static."+p+".com"; 
  if (e) return; 
  e = d.createElement(s); e.id = i; e.async = true; 
  e.src = h+"//"+u+"/p.js"; r.appendChild(e); 
})("script", "parsely", document); </script><div id="fb-root"></div> <script> (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=131721606912999";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk')); </script><script src="https://apis.google.com/js/platform.js" async defer></script><script async src="//platform.linkedin.com/in.js" type="text/javascript"></script><script> !function (d, s, id) { var js, fjs = d.getElementsByTagName(s)[0], p = /^http:/.test(d.location) ? 'http' : 'https'; if (!d.getElementById(id)) { js = d.createElement(s); js.id = id; js.src = p + '://platform.twitter.com/widgets.js'; fjs.parentNode.insertBefore(js, fjs); } }(document, 'script', 'twitter-wjs'); </script> <div class="mobile-menu"> <ul> <li><a href='/' >Home</a></li> <li><a href='/white-papers/' >White Papers</a></li> <li><a href='/events/webinars/' >Webinars</a></li> <li><a href='/d/' >Software Directory</a></li> <li><a href='/events/' title='Events Calendar' >Events Calendar</a></li> <li><a href='/about-us/' title='About Us' >About Us</a></li> <li><a href='/about-us/editorial-calendar/' >Editorial Calendar</a></li> <li><a href='/about-us/#contact' title='Contact' >Contact Us</a></li> <li><a href='http://www.simplermedia.com/mediakit/v1-00/titles/cmswire/' target='_blank' title='Advertise Here' >Advertise Here</a></li> </ul> </div><div class="wrapper"> <div id="header"> <div class="container"> <div class="row top-header hidden-sm hidden-xs hidden-md"> <div class="col-md-3"> <ul class="social-links"> <li> <a href='https://twitter.com/CMSWire' class='twitter' target='_blank' title='Twitter' > <i class="fa fa-twitter"></i> </a> </li> <li> <a href='https://www.linkedin.com/company/cmswire' class='linkedin' target='_blank' title='LinkedIn' > <i class="fa fa-linkedin"></i> </a> </li> <li> <a href='http://facebook.com/CMSWire' class='facebook' target='_blank' > <i class="fa fa-facebook"></i> </a> </li> <li> <a href='https://plus.google.com/+CMSWire' class='googleplus' target='_blank' title='Google+' > <i class="fa fa-google-plus"></i> </a> </li> <li> <a href='http://feeds.feedburner.com/CMSWire' class='rss' target='_blank' title='RSS Feed' > <i class="fa fa-rss"></i> </a> </li> </ul> </div> <div class="col-md-4 desktop-fix"> <div class="subscribe"> <form method="post" id="frmESub_Header" name="frmESub_Header" action="#null"
          onsubmit="return validateNLSubscribe('#txtEmlSub_Header', '#frmESub_Header', 'header');"> <input id="txtEmlSub_Header" type="text" placeholder="Enter email address..." /> <input type="button" value="Subscribe" onclick="$('#frmESub_Header').submit();return false;" /> </form> </div> </div> <div class="col-md-5 text-right hidden-sm hidden-xs hidden-md"> <ul class="secondary-menu"> <li><a href='/about-us/' target='_parent' title='About Us' >About Us</a></li> <li><a href='/about-us/editorial-calendar/' target='_parent' title='Editorial Calendar' >Editorial Calendar</a></li> <li><a href='/about-us/#contact' target='_parent' title='Contact' >Contact Us</a></li> <li><a href='https://www.simplermedia.com/brands/cmswire/' target='_blank' title='Advertise Here' >Advertise Here</a></li> </ul> </div> </div> <div class="row bottom-header"> <div class="col-md-3 logo-container">  <div class="mobile-menu-trigger"></div> <div class="mobile-search-trigger"></div>  <a href='/' > <img src="/~/media/346f68a07ac545a09971abfdb558e17a.png" srcset="/~/media/6b7896af281a4c20919737b0fad23ff2.png?mw=346&amp;mh=58&amp;hash=379B0B2D75C965C173FF218512ADA4707EC98E8B 2x" alt="CMSWire"> </a> </div> <div class="col-md-9 desktop-fix hidden-sm hidden-xs hidden-md"> <ul class="main-menu" id="myMenuAsyc"> <li top-menu-item> <a href='javascript:void(0);' >Channels</a> </li> <li top-menu-item> <a href='javascript:void(0);' >Featured Products</a> </li> <li top-menu-item> <a href='/white-papers/' >White Papers</a> </li> <li top-menu-item> <a href='/events/webinars/' >Webinars</a> </li> <li top-menu-item> <a href='/d/' >Software Directory</a> </li> <li top-menu-item> <a href='/events/' >Events</a> </li> </ul> <script> $jQ.get("/fragments/mainmenu.aspx", function (data, status) {
        $jQ("#myMenuAsyc").replaceWith(data);
        $jQ(".side-menu li a").hover(function () {
            var t = $(this).attr("rel");
            var container = $jQ(this).closest(".container");
            container.find("a").removeClass("active");
            $jQ(this).addClass("active");
            container.find(".tab-content").hide();
            $jQ(t).show();
            return false;

        });

        $jQ("li[top-menu-item]").hover(function () {
            var a = $jQ(this).find(".side-menu li a");
            a.removeClass("active");
            $jQ(a[0]).addClass("active");
            var container = $jQ(a[0]).closest(".container").find(".tab-content").hide();
            var t = $jQ(a[0]).attr("rel");
            $jQ(t).show();
        });
    }); </script> <ul class="main-menu"> <li class="search-site"> <div id="top-search-box"> <div class="CoveoSearchBox" data-activate-omnibox="true"></div> </div> </li> </ul> <script type="text/javascript"> //Coveo
    jQuery(function () {

        var customEndpoint = new Coveo.Rest.SearchEndpoint({
            restUri: 'http://www.cmswire.com/coveo/rest'
        })

        $jQ('#top-search-box').coveo('initSearchBox', 'http://www.cmswire.com/search/');
        $jQ('#top-search-box').find('.CoveoQueryBox').addClass("search-site").attr("placeholder", "Search");
        $jQ('<div style="clear: both;"></div><span class="search-icon"><i class="fa fa-search"></i></span>').insertAfter("#top-search-box .CoveoQueryBox.search-site");

        //custom row html building with highlighting
        function buildOmniBoxForOneRow(result) {
            var t = result.Title;
            var highlighted = [];
            var last = 0;
            for (var i = 0 ; i < result.titleHighlights.length ; i++) {
                var highLight = result.titleHighlights[i];

                highlighted.push(
                    t.slice(last, highLight.offset),
                    "<span class='coveo-highlight'>",
                    t.slice(highLight.offset, highLight.offset + highLight.length),
                    "</span>");
                last += highLight.offset + highLight.length
            }
            highlighted.push(t.slice(last))
            return $jQ("<div>" + highlighted.join("") + "</div>");
        }

        function buildOmniBoxContent(arrayOfValues, populateOmniBoxObject) {
            var resultsContainer = $jQ("<div></div>")
            for (var i = 0 ; i < arrayOfValues.length ; i++) {
                
                var oneRowOfContent = buildOmniBoxForOneRow(arrayOfValues[i])
                $jQ(oneRowOfContent).addClass("coveo-omnibox-selectable")
                $jQ(oneRowOfContent).addClass("coveo-top-field-suggestion-row")
                $jQ(oneRowOfContent).attr("data-href",arrayOfValues[i].raw.sysclickableuri);
                $jQ(oneRowOfContent).on("click keyboardSelect", function () {
                    populateOmniBoxObject.clear();
                    //populateOmniBoxObject.close();
                    window.location.href = $jQ(this).attr("data-href");
                })
                resultsContainer.append(oneRowOfContent);
            }

            return resultsContainer
        }

        var searchInterface = $jQ('#top-search-box');

        searchInterface.on("populateOmniBox", function (e, populateOmniBoxObject) {
            var wordToSearch = populateOmniBoxObject.completeQueryExpression.word;
            var regexToSearch = populateOmniBoxObject.completeQueryExpression.regex;

            var deferred = $jQ.Deferred();
            populateOmniBoxObject.rows.push({ deferred: deferred });

            var myQueryBuilder = new Coveo.Ui.QueryBuilder();
            myQueryBuilder.expression.add(wordToSearch);
            myQueryBuilder.constantExpression.add("@syssource=='SmgWeb_index_Source'");
            myQueryBuilder.numberOfResults = 8;
            var myQuery = myQueryBuilder.build();
            customEndpoint.search(myQuery).done(function (response) {
                if (response.queryError) {
                    //alert(response.message);
                    deferred.resolve({ element: undefined })
                } else {
                    deferred.resolve({
                        zIndex: 100, 
                        element: buildOmniBoxContent(response.results, populateOmniBoxObject)
                    });
                }
            })
        });
    }); </script> <style> .CoveoSearchInterface {
        height: auto;
        min-height: 16px;
    }

    .search-site .CoveoSearchButton {
        display: none;
    }

    .search-site .CoveoSearchBox {
        border-radius: 0;
        height: auto;
        overflow: visible;
    }

        .search-site .CoveoSearchBox > div {
            height: auto;
            overflow: visible;
            position: relative;
        }

    .CoveoQueryBox.search-site {
        border-radius: 0;
        font-size: 14px;
        padding-left: 1px;
        padding-bottom: 1px;
        height: auto;
    }

    .search-site .coveo-query-box-clear {
        display: none !important;
    }

    #top-search-box .coveo-omnibox {
        top: 27px;
    }

    #top-search-box .coveo-omnibox-header {
        background: none repeat scroll 0 0 #e2e2e2;
        color: #666666;
    }

    #top-search-box .coveo-top-suggestion-row, #top-search-box .coveo-top-field-suggestion-row, #top-search-box .coveo-top-analytics-suggestion-row, #top-search-box .coveo-top-field-suggestion-row {
        padding: 5px 7px 5px 14px;
        height: auto;
        text-overflow: initial;
        white-space: normal;
    }

    #top-search-box .coveo-top-suggestion-header, #top-search-box .coveo-top-field-suggestion-header, #top-search-box .coveo-top-analytics-suggestion-header, #top-search-box .coveo-omnibox-result-list-header {
        padding-left: 5px;
    }
    
    #top-search-box .coveo-icon-top-field {
        display: none;
    }

    #top-search-box .coveo-omnibox .coveo-omnibox-header .coveo-text {
        padding-left: 5px;
    } </style> </div> </div> </div> </div> <script type="text/javascript"> //Coveo.
    jQuery(function () {
        Coveo.Rest.SearchEndpoint.endpoints.default = new Coveo.Rest.SearchEndpoint({
            restUri: 'http://www.cmswire.com/coveo/rest'
        });
        Coveo.$('#searchBoxMobile').coveo('initSearchBox', 'http://www.cmswire.com/search/');
        Coveo.$('#searchBoxMobile').find('.CoveoQueryBox').addClass("search-mobile-site").attr("placeholder", "Search...");
        Coveo.$('#searchBoxMobile').find('.CoveoSearchButton').addClass("mobile-search-button").text("GO");
    }); </script> <div class="mobile-search"> <div class="container"> <div class="row"> <div id="searchBoxMobile"class="col-sm-12"> <div class="CoveoSearchBox" data-activate-omnibox="true"></div> </div> </div> </div> </div> <link rel="stylesheet" href="/bundles/public/search_mobile.css?v=21633266" /><div class="container"> <div class="row main-ad-block text-center hidden-xs"> <div class="col-sm-12 hidden-sm hidden-xs"> <div id='div-gpt-ad-1336852434508-10' class=''>  <script type='text/javascript'> if (typeof isMobile == "undefined" || isMobile == false) {
                    try {
                        googletag.cmd.push(function () {
                            googletag.display('div-gpt-ad-1336852434508-10');
                        });
                    } catch (e) {
                    }
                } </script> </div> </div> </div> <div class="row"> <div class="col-md-12 hidden-sm hidden-xs"> <ul class="topics"> <li>Channels</li> <li><a href='/customer-experience/' >Customer Experience</a></li> <li><a href='/digital-experience/' title='Digital Experience' >Digital Experience</a></li> <li><a href='/tag/dam/' >DAM</a></li> <li><a href='/digital-workplace/' >Digital Workplace</a></li> <li><a href='/sharepoint-office-365/' >SharePoint & Office 365</a></li> <li><a href='/web-cms/' title='Web CMS' >Web CMS</a></li> <li><a href='/mobile-enterprise/' title='Mobile Enterprise' >Mobile</a></li> <li><a href='/document-management/' >Document Mgt</a></li> </ul> </div> </div> <div class="row"> <div class="col-md-8"> </div> <div class="content-body col-md-8 col-sm-6 col-xs-12"> </div> <div class="col-md-4 col-sm-6 hidden-xs"> </div> </div> <div class="row"> <div itemscope itemtype="http://schema.org/Article"> <meta itemprop="url" content="http://www.cmswire.com/information-management/5-things-to-watch-for-at-microsoft-build-2017/" /> <meta itemprop="copyrightHolder" content="Simpler Media Group, Inc." /> <meta itemprop="publisher" content="CMSWire.com" /> <div class="col-md-12"> <h1 itemprop="headline"> 5 Things to Watch for at Microsoft Build 2017 </h1> </div> <div class="content-body col-md-8 col-sm-6 col-xs-12"> <div class="article-author"> <img src="/~/media/c8dd8494bde24d8799f1b51442443ff0.png?w=200&amp;h=200&amp;as=1&amp;hash=6004182800F7923AFA4C7A281E85DC8BFBCE21E3" alt="David Roe" width="100" height="100" class="author-avatar" /> <p> By <span itemprop="author" itemscope itemtype="http://schema.org/Person" class="author"><a href="/author/david-roe/" title="David Roe's profile" rel="author" itemprop="name">David Roe</a></span> <span class="separator">|</span> <em>May 9, 2017</em> <meta itemprop="datePublished" content="2017-05-09" /> </p> <p class="category hidden-sm hidden-xs"> CHANNEL: <a href="/information-management/">Information Management</a> </p> <a href="https://twitter.com/druadh20" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false"></a> </div> <div class="article-smallad"> <div id='div-gpt-ad-1336852434508-2' class=''>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-2');
                    });
                } catch (e) {
                } </script> </div>  </div> <div class="article-body" itemprop="articleBody"> <figure class="image-figure image-figure_featured-image article-vert insidevert1" itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <img src="/~/media/d7b6e6356cb34fdf8ca523367ac9434e.jpg?mw=320&amp;mh=240&amp;hash=EDC1945279AF3726944565BDB78F211D17561F50" srcset="/~/media/d7b6e6356cb34fdf8ca523367ac9434e.jpg?mw=640&mh=480&hash=EDC1945279AF3726944565BDB78F211D17561F50 2x" alt="Seattle skyline" class="block " itemprop="image" /> <figcaption> <span class="photo-cutline"><i class="fa fa-camera"></i>Though geared towards developers, Microsoft&#39;s Build conferences often give a clear direction where the company is heading in the year ahead</span> <span class="photo-credit">PHOTO: Ganapathy Kumar</span> </figcaption> </figure> <p>The Microsoft Build conference heads north this year, moving from its San Francisco base to kick off tomorrow in Seattle.&nbsp;</p> <p>The three-day conference will give developers a chance to catch up on the plethora of new products and upgrades Microsoft added to its portfolio in the last year as well as offer a sense of where the Redmond, Wash.-based company is headed in the year to come.&nbsp;</p> <p>Microsoft made a number of notable releases in the productivity space over the past 12 months that will likely feature highly at the conference as Microsoft fills in the missing holes in the roadmaps of several products.</p> <p>We'll be looking for more information specifically about Teams, about Office 365 in general as well as its individual components, about SharePoint on-premises, online and in hybrid deployments and about Azure.</p><div id='div-gpt-ad-1336852434508-3' class='article-vert insidevert2'>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-3');
                    });
                } catch (e) {
                } </script> </div> <p>Expect to hear more about Windows 10 too, especially now that Microsoft has a six-monthly update cycle, with some of the improvements already appearing in insider builds.</p> <p>Undoubtedly, Microsoft will also throw some curveballs into the event, so we will be following until the end.&nbsp;</p> <h2>5 Areas of Interest at Build 2017</h2> <p>But in the meantime, here are five things we will be watching:</p> <h3>1. Teams</h3> <p>One of the really big announcements over the year was the launch of<a href="http://www.cmswire.com/digital-workplace/microsoft-teams-now-generally-available-adds-muscle-to-collaboration-space/" target="_blank"> Microsoft Teams</a><a href="http://www.cmswire.com/digital-workplace/microsoft-teams-now-generally-available-adds-muscle-to-collaboration-space/" target="_blank"></a>, the collaborative working space for teams that <a href="http://www.cmswire.com/digital-workplace/office-365-groups-sharepoint-sites-microsoft-teams-where-do-i-collaborate/">left some people confused</a> as to where it fit in Microsoft's growing collaboration portfolio.&nbsp;</p> <p>Microsoft has already indicated that it still has a lot to do here, so expect at least one Teams-related announcement over the three days.</p> <p>The breakout sessions includes one dedicated to Teams working with Adobe Creative Cloud and Adobe Document Cloud, which enables teams to access, share and collaborate on assets from Adobe Creative Cloud, as well as send and track Adobe Sign agreements using bot and tab.</p> <p>There&rsquo;s no guarantee any announcements will come out of this, but the program does advertise a dive into how Microsoft used Teams extensibility framework, Adobe Creative Cloud API and Adobe Document Cloud API to build this integration.&nbsp;</p> <h3>2. Office</h3> <p>Microsoft recently announced changes to how&nbsp;<a href="http://www.cmswire.com/information-management/microsoft-sets-a-soft-expiration-date-on-standalone-office-deployments-more-news/" target="_blank">users will be able to access Office</a>&nbsp;that will go into effect in 2020.&nbsp;The changes include some tight limitations on the use of standalone versions of Office, including the 2016 version.</p> <p>The move is calculated to push as many people onto the cloud as possible, with the selling point that it gives businesses access to improvements as they are introduced.</p> <p>Of particularly note among the sessions is one titled,"File Collaboration and Sharing Experiences with OneDrive, SharePoint, and Microsoft Graph." According to the program this will look at connecting Microsoft Graph for programmatic access to files across OneDrive and SharePoint, among other things.</p> <h3>3. SharePoint</h3> <p>After the release of <a href="http://www.cmswire.com/social-business/sharepoint-2016-9-experts-weigh-in/" target="_blank">SharePoint 2016</a>&nbsp;and SharePoint Framework over the past year it&rsquo;s only to be expected that the conference will have an ongoing focus on SharePoint and how Framework can help it.</p> <p>One session will be focused on building a modern workplace, including team spaces, departmental sites and organizational portals, using modern web development technologies in SharePoint. It will also walk developers through the SharePoint Framework extensibility roadmap and timeline.</p> <h3>4. Cortana </h3> <p>Cortana will also be in the spotlight this week, especially following this week's announcement of a fall shipping date for the Invoke speaker, the Microsoft Cortana-powered answer to the Google Home and Amazon Echo.</p> <p>According to Microsoft, the new speaker will make and receive calls with Skype, control Microsoft&rsquo;s music app Groove, and improve productivity with Cortana.</p> <p>Microsoft expects Invoke to control many IoT devices using the Cortana Skills Kit, which the company announced back in December with an expected February release which came and went with little word from Microsoft.</p> <p>It looks as if the company will break its silence this week. Build includes a number of sessions on Cortana Skills Kit, including one designed to walk users through the creation of a Cortana Skill, from inception to publishing.&nbsp;</p> <h3>5. Bots</h3> <p>Microsoft officials spent a good amount of time during Build last year discussing the future of Bots and how the company sees them fitting in its overall portfolio. But with the notable exception of Bots for Skype, the past year hasn't seen much action in the space from Microsoft.&nbsp;</p> <p>Bots will nevertheless return to Build once again this year with a number of sessions on the topic, including one that focuses on Bot capabilities, patterns and principles and how Microsoft&rsquo;s partners will work with the company in this area.&nbsp;</p> <h2>Setting the Course for the Year Ahead</h2> <p>This is only a small taste of what&rsquo;s to come over the next three days. As&nbsp;usual a lot of what will be on show, or discussed during the conference, will set the agenda for Microsoft over the coming year.</p> </div> <div class="social-bar"> <div class="addthis_sharing_toolbox"></div> <div class="break visible-xs"></div> <div class="widget-share comments-widget"> <img src="/Areas/Public/Content/images/comments-icon.png" alt="Comments"> <a href="#comments" data-disqus-identifier="eb047e0b62f749f0bd149ab6548cad61" >0 Comments</a> </div> </div> <div id='div-gpt-ad-1336852434508-1' class=''>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-1');
                    });
                } catch (e) {
                } </script> </div><div class="tabs articles-tabs hidden-sm hidden-xs"> <ul class="tabs-menu"> <li><a href="#top-articles">Top Articles</a></li> <li><a href="#related-articles">Related Articles</a></li> <li><a href="#recent-comments">Recent Comments</a></li> </ul> <div id="top-articles"> <ul> <li><a href="/digital-experience/how-information-architecture-improves-customer-experience/">How Information Architecture Improves Customer Experience</a></li> <li><a href="/information-management/forresters-ecm-wave-falls-flat/">Forrester&#39;s ECM Wave Falls Flat</a></li> <li><a href="/marketing-automation/mailchimp-gives-away-its-marketing-automation-tools/">MailChimp Gives Away Its Marketing Automation Tools</a></li> <li><a href="/information-management/sold-thoma-bravo-buys-lexmarks-software-business-sells-part-to-hyland/">Sold! Thoma Bravo Buys Lexmark&#39;s Software Business, Sells Part to Hyland</a></li> <li><a href="/digital-experience/bloomreach-post-hippo-acquisition-unveils-digital-experience-platform/">BloomReach, Post-Hippo Acquisition, Unveils Digital Experience Platform</a></li> </ul> </div> <div id="related-articles"> <ul> <li><a href="/information-management/5-things-to-watch-for-at-microsoft-build-2017/" title="5 Things to Watch for at Microsoft Build 2017">5 Things to Watch for at Microsoft Build 2017</a></li> <li><a href="/information-management/report-ddos-attacks-have-slowed-but-increased-in-size/" title="Report: DDoS Attacks Have Slowed, But Increased in Size ">Report: DDoS Attacks Have Slowed, But Increased in Size </a></li> <li><a href="/information-management/put-business-intelligence-in-employees-hands-with-shared-libraries/" title="Put Business Intelligence in Employees&#39; Hands With Shared Libraries">Put Business Intelligence in Employees&#39; Hands With Shared Libraries</a></li> <li><a href="/information-management/gartner-closes-33b-ceb-buy-it-operational-hurdles-more-news/" title="Gartner Closes $3.3B CEB Buy, IT Operational Hurdles, More News">Gartner Closes $3.3B CEB Buy, IT Operational Hurdles, More News</a></li> <li><a href="/information-management/slack-improve-workflows-with-new-message-menus-more-news/" title="Slack Improves Workflows With New Message Menus, More News">Slack Improves Workflows With New Message Menus, More News</a></li> </ul> </div> <div id="recent-comments"> <div id="footer-commented-on"></div> <script type="text/javascript" src="http://cmswire.disqus.com/recent_comments_widget.js?num_items=5&amp;hide_avatars=0&amp;avatar_size=24&amp;excerpt_length=150"></script> </div> </div><div class="row useful-article hidden-sm hidden-xs"> <div class="col-md-6"> <div class="box gray"> <div class="title-header mb20"> <div class="h2">Useful Article?</div> </div> <div class="mb15"> <div class="addthis_toolbox addthis_20x20_style"> <a class="addthis_button_email email-this" style="float:left;"> <img src="/Areas/Public/Content/images/email-icon.png"
                             class="v-middle" alt="Email this Article" style="margin-right:10px;" />Email this Article </a> <a class="addthis_button_stumbleupon" style="float:left;"> <img src="/Areas/Public/Content/images/stumbleupon-icon.png" alt="Stumble This" class="v-middle" style="width:24px;height:24px;margin-right:10px;" />Stumble This </a> </div> <br clear="all" /> </div> <div class="mb15"> <a href="https://twitter.com/cmswire" class="twitter-follow-button">Follow @CMSWire</a> </div> <p class="tags"> <strong>Tags</strong> <a href="/tag/bots/" rel="tag">bots</a>, <a href="/tag/build-2017/" rel="tag">build 2017</a>, <a href="/tag/cortana/" rel="tag">cortana</a>, <a href="/tag/ecm/" rel="tag">ecm</a>, <a href="/tag/eim/" rel="tag">eim</a>, <a href="/tag/information-management/" rel="tag">information management</a>, <a href="/tag/microsoft/" rel="tag">microsoft</a>, <a href="/tag/office/" rel="tag">office</a>, <a href="/tag/office-365/" rel="tag">office 365</a>, <a href="/tag/sharepoint/" rel="tag">sharepoint</a> </p> </div> </div> <div class="col-md-6 text-center"> <div id='div-gpt-ad-1336852434508-0' class=''>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-0');
                    });
                } catch (e) {
                } </script> </div> </div> </div> <div class="spacer">&nbsp;</div> <a name="comments"></a> <script type="text/javascript"> function disqus_config() {
        this.callbacks.onNewComment = [function () { _nct.push(['_trackEvent', 'comment']); }];
    } </script> <div id="comments"></div> <div id="disqus_thread"></div> <script type="text/javascript"> var disqus_identifier = 'eb047e0b62f749f0bd149ab6548cad61';
    var disqus_title = '5 Things to Watch for at Microsoft Build 2017'; </script> <script type="text/javascript" src="http://cmswire.disqus.com/embed.js"></script> <noscript>Please enable JavaScript to view the <a href="http://disqus.com/?ref_noscript=cmswire">comments powered by Disqus.</a></noscript> <div class="box gray hidden-sm hidden-xs"> <div class="title-header"> <div class="h2">Resources</div> </div> <ul class="events-list"> <li> <a href='https://www.dwexperience.com/2017/' target='_blank' title='Digital Workplace Conference 2017' >Digital Workplace Conference</a><br> <p></p> </li> <li> <a href='http://www.dxsummit.com/' target='_blank' title='DX Summit' >Digital Customer Experience Summit</a><br> <p></p> </li> <li> <a href='/d/document-management-software-c000018' target='_blank' title='Document Management Software List' >Document Management Software</a><br> <p></p> </li> <li> <a href='/newsletter/sign-up/' >Digital Experience Newsletter</a><br> <p></p> </li> <li> <a href='/cms/web-cms/7-rules-for-selecting-the-right-content-management-system-023026.php' target='_blank' title='7 Rules for Selecting the Right Content Management System' >Selecting a Web CMS</a><br> <p></p> </li> <li> <a href='http://www.cylogy.com' target='_blank' >Sitecore Consultant</a><br> <p></p> </li> <li> <a href='http://www.cmswire.com/digital-workplace/what-the-heck-is-a-digital-workplace-anyway/' title='What is the Digital Workplace?' >What is the Digital Workplace?</a><br> <p></p> </li> </ul> </div> <div class="box gray"> <div class="title-header mb20"> <p class="view-more-events hidden-sm hidden-xs"><a href="/events/">View All Events</a> <a href="/events/#add-event">Add Your Event</a> <a href="">Events RSS</a></p> <div class="h2">Featured Events</div> </div> <ul class="events-list with-date without-border tk-museo-sans"> <li> <span class="date">May <strong>10</strong></span> <a href="http://hubs.ly/H06CCJR0">[Earley Executive Roundtable] Session 3: Robo-Banking &amp; Robo-Advisors </a> </li> <li> <span class="date">May <strong>11</strong></span> <a href="http://bit.ly/2pTnl7T">[CMSWire Webinar] Tackle the Big 3 of Information Governance</a> </li> <li> <span class="date">May <strong>16</strong></span> <a href="http://bit.ly/2pDptSq">[CMSWire Webinar] 5 Tactics to Recover 60% of Lost Revenue from Abandoned Carts</a> </li> <li> <span class="date">May <strong>18</strong></span> <a href="http://bit.ly/2mXk4rg">[DW Webinar Series 2] The Intersection of Intranets and Employee Experience</a> </li> <li> <span class="date">May <strong>23</strong></span> <a href="http://bit.ly/2pE3pJA">[CMSWire Webinar] 4 Essential Capabilities for a Successful Digital Workplace Strategy</a> </li> <li> <span class="date">May <strong>24</strong></span> <a href="http://hubs.ly/H06CG6X0">[Earley Executive Roundtable] Session 4: Commerce and Virtual Sales Assistants</a> </li> <li> <span class="date">May <strong>31</strong></span> <a href="http://smg.io/2qqjz9V">[Episerver Webinar] Accelerate Time to Value: How to prioritize digital experience delivery</a> </li> </ul> </div> </div> </div> <link rel="stylesheet" href="/bundles/public/articlecontent.css" /> <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.js"></script> <script src="/Areas/Public/Content/js/jquery.fancybox.js" type="text/javascript"></script> <script> jQuery(document).ready(function () {
        jQuery(".fancyBoxImage").wrap(function () {
            return "<a class='fancyBoxLink' href='" + $jQ(this).attr("src") + "'></a>";
        })
        jQuery(".fancyBoxLink").each(function () {

            //to get full size image from sitecore we need to remove w= and h= paramenter from image src
            var fullImageSrc = $jQ(this).attr("href")
                .replace("&w=", "&ow=")
                .replace("?w=", "?ow=")
                .replace("&h=", "&oh=")
                .replace("?h=", "?oh=");

            jQuery(this).fancybox({
                fitToView: false,
                closeBtn: true,
                scrolling: 'yes',
                href: fullImageSrc
            });
        });
    }); </script> <div class="col-md-4 col-sm-6 hidden-xs article-side-wrap"> <div id='div-gpt-ad-1336852434508-8' class='article-side-300x600'>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-8');
                    });
                } catch (e) {
                } </script> </div> </div> </div> </div><div class="desktop-footer hidden-sm hidden-xs"> <div class="container"> <div class="row"> <div class="col-md-4"> <div class="group"> <div class="h4">About Us</div> <p>CMSWire is a popular web magazine published by <a href="http://www.simplermedia.com">Simpler Media Group</a>. We provide news, advice and analysis for professionals driving digital customer experience strategy, evolving the digital workplace and creating intelligent information management practices. The CMSWire team produces 500+ authoritative articles per quarter for a community of over 750,000 market influencers.</p> <p><a href="/about-us/">Read more</a> about us or learn how to <a href="http://www.simplermedia.com/brands/cmswire/">advertise here</a>. We also have a <a href="/advisory-board/">Reader Advisory Board</a>.</p> <strong>More:</strong> <p><a href="/about-us/editorial-calendar/">Monthly Editorial Calendar</a> <br /> <a href="/about-us/submission-guidelines/" target="_parent">Article Submission Guidelines</a><br /> <a href="https://www.dwexperience.com/" title="DW Experience">DW Experience Conference</a><br /> <a href="https://www.dxsummit.com/" title="DX Summit">DX Summit Conference</a><br /> <a href="http://www.simplermedia.com/brands/cmswire/" target="_blank">Advertiser Media Kit</a> </p> </div> <div class="group"> <div class="h4">Stay In the Loop</div> <ul class="social-list"> <li> <a href='https://twitter.com/CMSWire' class='twitter' target='_blank' title='Twitter' > <i class="fa fa-twitter"></i> </a> </li> <li> <a href='https://www.linkedin.com/company/cmswire' class='linkedin' target='_blank' title='LinkedIn' > <i class="fa fa-linkedin"></i> </a> </li> <li> <a href='http://facebook.com/CMSWire' class='facebook' target='_blank' > <i class="fa fa-facebook"></i> </a> </li> <li> <a href='https://plus.google.com/+CMSWire' class='googleplus' target='_blank' title='Google+' > <i class="fa fa-google-plus"></i> </a> </li> <li> <a href='http://feeds.feedburner.com/CMSWire' class='rss' target='_blank' title='RSS Feed' > <i class="fa fa-rss"></i> </a> </li> </ul> </div> <div class="group"> <div class="h4">Get Our Newsletter</div> <form method="post" id="frmESub_Footer" name="frmESub_Footer" action="#null" class="footer-subscribe"
          onsubmit="return validateNLSubscribe('#txtEmlSub_Footer', '#frmESub_Footer', 'footer');"> <input id="txtEmlSub_Footer" type="text" placeholder="Enter email address..." /> <input type="button" value="Subscribe" onclick="$('#frmESub_Footer').submit(); return false;" /> </form> </div> </div> <div class="col-md-4"> <div class="h4">Most Popular Articles</div> <ul class="articles-list"> <li> <a href="/digital-experience/how-information-architecture-improves-customer-experience/" title="How Information Architecture Improves Customer Experience (2866, 2866)">How Information Architecture Improves Customer Experience</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/digital-experience/how-information-architecture-improves-customer-experience/#disqus_thread'"
                   data-disqus-identifier="3312f595d30246e19ccb2b6cf3a5473f" >view comments</a> </span> </li> <li> <a href="/information-management/forresters-ecm-wave-falls-flat/" title="Forrester&#39;s ECM Wave Falls Flat (2195, 2195)">Forrester&#39;s ECM Wave Falls Flat</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/information-management/forresters-ecm-wave-falls-flat/#disqus_thread'"
                   data-disqus-identifier="c3561f7399914be7ae10e87dc3e30170" >view comments</a> </span> </li> <li> <a href="/marketing-automation/mailchimp-gives-away-its-marketing-automation-tools/" title="MailChimp Gives Away Its Marketing Automation Tools (2119, 2119)">MailChimp Gives Away Its Marketing Automation Tools</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/marketing-automation/mailchimp-gives-away-its-marketing-automation-tools/#disqus_thread'"
                   data-disqus-identifier="bfc3e2a0009a4beab80cd4098a1c3f09" >view comments</a> </span> </li> <li> <a href="/information-management/sold-thoma-bravo-buys-lexmarks-software-business-sells-part-to-hyland/" title="Sold! Thoma Bravo Buys Lexmark&#39;s Software Business, Sells Part to Hyland (1944, 1944)">Sold! Thoma Bravo Buys Lexmark&#39;s Software Business, Sells Part to Hyland</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/information-management/sold-thoma-bravo-buys-lexmarks-software-business-sells-part-to-hyland/#disqus_thread'"
                   data-disqus-identifier="2f8e6f5d667547e591d4785ca6584e36" >view comments</a> </span> </li> <li> <a href="/digital-experience/bloomreach-post-hippo-acquisition-unveils-digital-experience-platform/" title="BloomReach, Post-Hippo Acquisition, Unveils Digital Experience Platform (1859, 1859)">BloomReach, Post-Hippo Acquisition, Unveils Digital Experience Platform</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/digital-experience/bloomreach-post-hippo-acquisition-unveils-digital-experience-platform/#disqus_thread'"
                   data-disqus-identifier="c0f434ef36a64727b82ccd0074c5c762" >view comments</a> </span> </li> </ul> </div> <div class="col-md-4"> <div class="h4">Recent Comments</div> <script type="text/javascript" src="http://cmswire.disqus.com/recent_comments_widget.js?num_items=5&amp;amp;hide_avatars=0&amp;amp;avatar_size=24&amp;amp;excerpt_length=150"></script> </div> </div> </div> </div> <div class="final-footer"> <div class="container"> <div class="row"> <div class="col-xs-12 text-center"> <p>&copy; 2017 <a href="http://www.simplermedia.com">Simpler Media Group, Inc</a>. All rights reserved. <br class="visible-sm visible-xs" /> <a href="/about-us/privacy-policy/">Privacy Policy</a>. <a href="http://www.simplermedia.com/mediakit/v1-00/titles/cmswire/legal.php" target="_blank">Terms of Use</a>.</p> <div> Powered by <a href="http://sitecore.net/" target="_blank" rel="nofollow">Sitecore</a> and <a href="http://www.coveo.com/en/solutions/coveo-for-sitecore" target="_blank" rel="nofollow">Coveo</a>.
                    SMGP v2.1.6332.66. </div> </div> </div> </div> </div> <div id='div-gpt-ad-1336852434508-6' class=''>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1336852434508-6');
                    });
                } catch (e) {
                } </script> </div><div id='div-gpt-ad-1352353012906-0' class=''>  <script type='text/javascript'> try {
                    googletag.cmd.push(function () {
                        googletag.display('div-gpt-ad-1352353012906-0');
                    });
                } catch (e) {
                } </script> </div> </div> <script src="/areas/public/content/js/magnific-popup.js?v=21633266"></script> <script type="text/javascript"> (function() {
  var didInit = false;
  function initMunchkin() {
    if(didInit === false) {
      didInit = true;
      Munchkin.init('706-YIA-261');
    }
  }
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = document.location.protocol + '//munchkin.marketo.net/munchkin.js';
  s.onreadystatechange = function() {
    if (this.readyState == 'complete' || this.readyState == 'loaded') {
      initMunchkin();
    }
  };
  s.onload = initMunchkin;
  document.getElementsByTagName('head')[0].appendChild(s);
})(); </script><script type="text/javascript">  var disqus_shortname = 'cmswire';

    	(function () {
        	var s = document.createElement('script'); s.async = true;
        	s.type = 'text/javascript';
        	s.src = 'http://' + disqus_shortname + '.disqus.com/count.js';
        	(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
    	
		}()); </script> <script  async="async" type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54ecf65f14a7b7c2"></script> <script> var addthis_tw_handle = "CMSWire";
var addthis_tw_author = "";

try { addthis_tw_author = jQuery("meta[name*=creator]").attr("content").replace('@',''); } catch (e) {}
if (addthis_tw_author != '') { addthis_tw_handle = addthis_tw_author; }

var addthis_share = addthis_share || {};
addthis_share = { 
  passthrough : { twitter: {via: addthis_tw_handle, related: 'cmswire,thedxsummit,bdunwood,writenoreen'}}, 
  shorteners : {bitly: {}},
  url_transforms : {
  	add: {
  		utm_source: '{{code}}',
  		utm_medium: 'social',
  		utm_campaign: 'cm',
  		utm_content: 'addthis_share: {{title}}'
  	},
  	shorten: {twitter: 'bitly'}
  }
}; </script><script type="text/javascript"> adroll_adv_id = "BIOY564D6JH6ZI6JXOB2J6";
    adroll_pix_id = "I6MCTRCPYBFCTPK23Y27PP";
    /* Updated: 23-Jun-2016 */

    (function () {
        var _onload = function(){
            if (document.readyState && !/loaded|complete/.test(document.readyState)){setTimeout(_onload, 10);return}
            if (!window.__adroll_loaded){__adroll_loaded=true;setTimeout(_onload, 50);return}
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
                document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
        };
        if (window.addEventListener) {window.addEventListener('load', _onload, false);}
        else {window.attachEvent('onload', _onload)}
    }()); </script> <script type='text/javascript'> var _sf_async_config = (typeof sf_async_config !== 'undefined') ? sf_async_config : {};
    _sf_async_config.uid = 9908;
    _sf_async_config.domain = 'cmswire.com';
    _sf_async_config.useCanonical = true;
    (function() {
        function loadChartbeat() {
            window._sf_endpt = (new Date()).getTime();
            var e = document.createElement('script');
            e.setAttribute('language', 'javascript');
            e.setAttribute('type', 'text/javascript');
            e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
            document.body.appendChild(e);
        }
        var oldonload = window.onload;
        window.onload = (typeof window.onload != 'function') ?
            loadChartbeat : function() {
                oldonload();
                loadChartbeat();
            };
    })(); </script><a href="#dv_nl-dl-01a" class="nl-popup nl-pop-01a mfp-hide">NL-01a</a> <div id="dv_nl-dl-01a" class="nl-popup nl-prompt-01a mfp-hide"> <div class="nl-dialog"> <div class="nl-dialog-inner"> <div class="left"> <div class="h3">Get the CMSWire Newsletter</div> <ul> <li>Receive concise summaries of what's happening in your industry</li> <li>Get access to exclusive reports, white papers and webinars</li> </ul> </div> <div class="right"> <br /> <div class="h4'>Join more than 55,000 of your peers:</div> <form method="post" id="frmESub_Dialog" name="frmESub_Dialog" action="#"
					onsubmit="if(validateEmail($jQ('#txtEmlSub_Dialog').val()) == false){
						alert('Please enter a valid email address.'); 
						$jQ('#txtEmlSub_Dialog').focus(); return false;
						} else {
							gaRecordEvent('Click - Internal', 'Dialog', 'Email Subscribe');
							gaRecordEvent('Featured', 'Subscribe-Clicked', '');
							
							var dfpRedir = $jQ('#nl-frm-hdn-click').val();
							var act = '/newsletter/sign-up/?smg_medium=display&smg_content=Popup-GEN-01-Delay-' +$jQ('#nl-frm-hdn-delay').val();
							act = act + '&smg_campaign=Newsletter-Signup&smg_source=cmswire.com&form=dialog';
							act = act + '&from=' +$jQ('#txtEmlSub_Dialog').val();
							act = act + '&src=/';
							
							if (dfpRedir != '') {
								act = dfpRedir + 'http://www.cmswire.com' + act;
								window.location = act;
								return false;
							} else {
								document.frmESub_Dialog.action = act;
							}
							
							return true; 
						}"> <input type="email" id="txtEmlSub_Dialog" placeholder="Email address" class="inputEmail" 
					name="from" required /> <input id="nl-frm-hdn-delay" type="hidden" name="display-delay" value="0" /> <input id="nl-frm-hdn-click" type="hidden" name="dfp-click" /> <input id="btnSubmit_Dialog" type="submit" value="Sign me up!" class="btnSubmit" /> </form> <p><img src="/~/media/a474bc65ac0e4c80a142e32fc37d4021.png" alt="lock" /> We take your privacy seriously</p> </div> </div> </div> </div> <a href="#dv_nl-dl-02a" class="nl-popup nl-pop-02a mfp-hide">NL-03a</a> <div id="dv_nl-dl-02a" class="nl-popup nl-prompt-02 mfp-hide"> <div class="header"> <div class="h2">Get the CMSWire Newsletter</div> <a href="#null" class="close" onClick="$jQ.magnificPopup.close();return false;"></a> </div>  <div class="content"> <div class="col-left"> <p class="benefit">You'll receive:</p> <ul> <li class="benefits">Exclusive Articles</li> <li class="benefits">Latest White Papers</li> <li class="benefits">Early Event Invites</li> </ul> </div>  <div class="col-right"> <p class="join">Join <span class="sub-number">55,000 subscribers</span> and growing</p> <form method="post" action="#"
					onsubmit="if(validateEmail($jQ('#nlp02a_txtEmail').val()) == false){
						alert('Please enter a valid email address.'); 
						$jQ('#nlp02a_txtEmail').focus(); return false;
						} else {
							gaRecordEvent('Click - Internal', 'Dialog', 'Email Subscribe');
							gaRecordEvent('Featured', 'Subscribe-Clicked', '');
							
							var dfpRedir = $jQ('#nlp02a_hdnClick').val();
							var act = '/newsletter/sign-up/?smg_medium=display&smg_content=Popup-GEN-02a-Delay-' +$jQ('#nlp02a_hdnDelay').val();
							act = act + '&smg_campaign=Newsletter-Signup&smg_source=cmswire.com&form=dialog';
							act = act + '&from=' +$jQ('#nlp02a_txtEmail').val();
							act = act + '&src=/';
							
							if (dfpRedir != '') {
								act = dfpRedir + 'http://www.cmswire.com' + act;
								window.location = act;
								return false;
							} else {
								this.action = act;
							}
							return true; 
						}"> <input type="email" id="nlp02a_txtEmail" name="from" placeholder="Email address" required /> <input id="nlp02a_hdnDelay" type="hidden" name="display-delay" value="0" /> <input id="nlp02a_hdnClick" type="hidden" name="dfp-click" /> <input id="nlp02a_btnSubmit" class="submit" type="submit" value="Subscribe Today" /> </form> <p class="info"><span class="security"></span>We take your privacy seriously</p> </div> </div> </div> <div id="dv_nl-dl-02b" class="nl-popup nl-prompt-02 mfp-hide"> <div class="header"> <div class="h2">Get the CMSWire Newsletter</div> <a href="#null" class="close" onClick="$jQ('#dv_nl-dl-02a').dialog('close');"></a> </div>  <div class="content"> <div class="col-left"> <p class="join">Join <span class="sub-number">55,000 subscribers</span> and growing</p> <form method="post" action="#"
					onsubmit="if(validateEmail($jQ('#nlp02b_txtEmail').val()) == false){
						alert('Please enter a valid email address.'); 
						$jQ('#nlp02b_txtEmail').focus(); return false;
						} else {
							gaRecordEvent('Click - Internal', 'Dialog', 'Email Subscribe');
							gaRecordEvent('Featured', 'Subscribe-Clicked', '');
							
							var dfpRedir = $jQ('#nlp02b_hdnClick').val();
							var act = '/newsletter/sign-up/?smg_medium=display&smg_content=Popup-GEN-02b-Delay-' +$jQ('#nlp02b_hdnDelay').val();
							act = act + '&smg_campaign=Newsletter-Signup&smg_source=cmswire.com&form=dialog';
							act = act + '&from=' +$jQ('#nlp02b_txtEmail').val();
							act = act + '&src=/';
							
							if (dfpRedir != '') {
								act = dfpRedir + 'http://www.cmswire.com' + act;
								window.location = act;
								return false;
							} else {
								this.action = act;
							}
							return true; 
						}"> <input type="email" id="nlp02b_txtEmail" name="from" placeholder="Email address" required /> <input id="nlp02b_hdnDelay" type="hidden" name="display-delay" value="0" /> <input id="nlp02b_hdnClick" type="hidden" name="dfp-click" /> <input id="nlp02b_btnSubmit" class="submit" type="submit" value="Subscribe Today" /> </form> <p class="info"><span class="security"></span>We take your privacy seriously</p> </div>  <div class="col-right"> <p class="benefit">You'll receive</p> <ul> <li class="benefits">Exclusive Articles</li> <li class="benefits">Latest White Papers</li> <li class="benefits">Webinar Invites</li> </ul> </div>  </div> </div> <a href="#dv_nl-dl-03a" class="nl-popup nl-pop-03a mfp-hide">NL-03a</a> <div id="dv_nl-dl-03a" class="nl-prompt-03a mfp-hide nl-popup"> <a href="#null" class="close" onClick="jQuery.magnificPopup.close();return false;"></a> <div class="content"> <div class="h2">Join 55,000<br /><span>of your peers</span></div> <p class="join">Get the CMSWire newsletter.<br /> Access exclusive news, best practices and events.</p> <form method="post" action=""
					onsubmit="if(validateEmail($jQ('#nlp03a_txtEmail').val()) == false){
						alert('Please enter a valid email address.'); 
						$jQ('#nlp03a_txtEmail').focus(); return false;
						} else {
							gaRecordEvent('Click - Internal', 'Dialog', 'Email Subscribe');
							gaRecordEvent('Featured', 'Subscribe-Clicked', '');
                                                        _gaq.push(['_trackEvent', 'NL-Prompt', 'Submit', '03a']);	
							
							var dfpRedir = $jQ('#nlp03a_hdnClick').val();
							var act = '/newsletter/sign-up/?smg_medium=display&smg_content=Popup-GEN-03a-Delay-' +$jQ('#nlp03a_hdnDelay').val();
							act = act + '&smg_campaign=Newsletter-Signup&smg_source=cmswire.com&form=dialog';
							act = act + '&from=' +$jQ('#nlp03a_txtEmail').val();
							act = act + '&src=/';
							
							if (dfpRedir != '') {
								act = dfpRedir + 'http://www.cmswire.com' + act;
								window.location = act;
								return false;
							} else {
								//this.action = act;
                                                                window.location = act;
                                                                return false;
							}
							return true; 
						}"> <input type="email" id="nlp03a_txtEmail" name="from" placeholder="Enter your email address..." required /> <input id="nlp03a_hdnDelay" type="hidden" name="display-delay" value="0" /> <input id="nlp03a_hdnClick" type="hidden" name="dfp-click" /> <input id="nlp03a_btnSubmit" class="submit" type="submit" value="Subscribe" /> </form> </div>  </div><script type="text/javascript"> window.cookieconsent_options = {"message":"FYI - this site uses cookies to tailor your experience. Your use of our site indicates that you agree to this.","dismiss":"Got it!","learnMore":"More info","link":"http://www.cmswire.com/about-us/privacy-policy/","theme":"dark-bottom"}; </script> <script type="text/javascript" src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/1.0.10/cookieconsent.min.js" async="async"></script> <script type="text/javascript" src="/public/common/dynamic.js?ids=eaedb9f2-ec27-449b-b2bf-1d7bd824f9bf"></script> </body> </html> 