 <!DOCTYPE html> <html lang="en" xmlns="http://www.w3.org/1999/xhtml"> <head> <title>Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us</title> <link rel="canonical" href="https://www.cmswire.com/digital-workplace/open-sources-twentieth-anniversary-and-where-the-next-twenty-years-will-take-us/" /> <meta name="news_keywords" content="open source 20th anniversary"> <script> var contentAuthor = 'David Roe';
        var contentPublishDate = '2018-02-02';
        var contentTemplate = 'article';
        var contentItemId = '{0DF6B948-9717-464F-A6A3-0E640311CCE9}'; </script> <meta name="description" content="Experts share their thoughts on the rends that will dominate the future of open source computing." /> <meta name="twitter:card" content="summary_large_image" /> <meta name="twitter:image" content="https://www.cmswire.com/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg" /> <meta property="og:image" content="https://www.cmswire.com/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg" /> <meta name="twitter:site" content="@CMSWire" /> <meta name="twitter:creator" content="@druadh20" /> <meta name="twitter:url" content="https://www.cmswire.com/digital-workplace/open-sources-twentieth-anniversary-and-where-the-next-twenty-years-will-take-us/" /> <meta name="twitter:title" content="Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us" /> <meta name="twitter:description" content="Experts share their thoughts on the rends that will dominate the future of open source computing." /> <meta name="og:description" value="Experts share their thoughts on the rends that will dominate the future of open source computing." /> <meta property="og:type" content="article" /> <meta property="article:publisher" content="https://www.facebook.com/CMSWire" /> <meta name="parsely-metadata" content="{ 'type': 'editorial', 'category': 'digital workplace', 'sophistication': 'general', 'keywords': ['open source', 'information management', 'osi', 'eim', 'foss', 'foss update', 'open source software', 'open source technologies', 'category: digital workplace', 'type: editorial', 'utype: staff'] }"> <script type="application/ld+json"> {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "@id": "#this",
        "headline": "Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us",
        "mainEntityOfPage": "https://www.cmswire.com/digital-workplace/open-sources-twentieth-anniversary-and-where-the-next-twenty-years-will-take-us/",
        "url": "https://www.cmswire.com/digital-workplace/open-sources-twentieth-anniversary-and-where-the-next-twenty-years-will-take-us/",
            "thumbnailUrl": "https://www.cmswire.com/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg",
            "image": "https://www.cmswire.com/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg",
                    "dateCreated": "2018-02-02T20:39:25",
            "datePublished": "2018-02-02T20:39:25",
            "dateModified": "2018-02-02T20:39:25",
        "articleSection": "Digital Workplace",
        "creator": "David Roe",
        "keywords": ["open source", "information management", "osi", "eim", "foss", "foss update", "open source software", "open source technologies", "category: digital workplace", "type: editorial", "utype: staff"],
        "author": {"type": "Person","name":"David Roe"},
        "publisher": {"type":"Organization", "name":"CMSWire.com",
        "logo":{"type":"ImageObject", "url":"https://www.cmswire.com/~/media/346f68a07ac545a09971abfdb558e17a.png"}},
        "copyrightHolder": "Simpler Media Group, Inc."
        } </script> <link rel="shortcut icon" href="/~/media/0f48619f063d48bfa500ab082f28eda7.png" type="image/x-icon" /><script type="text/javascript" src="//use.typekit.net/gtl4etw.js"></script> <script type="text/javascript">try{Typekit.load();}catch(e){}</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">window.NREUM||(NREUM={});NREUM.info = {"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"5205defa29","applicationID":"13012606","transactionName":"YwRVMUJZDBYEW0RRVlpOejNzFzEMEV1TV0tRIlgLREoNCQldQhdwWgVSHQ==","queueTime":0,"applicationTime":312,"ttGuid":"FCD235B13E3D99C7","agent":""}</script><script type="text/javascript">window.NREUM||(NREUM={}),__nr_require=function(e,t,n){function r(n){if(!t[n]){var o=t[n]={exports:{}};e[n][0].call(o.exports,function(t){var o=e[n][1][t];return r(o||t)},o,o.exports)}return t[n].exports}if("function"==typeof __nr_require)return __nr_require;for(var o=0;o<n.length;o++)r(n[o]);return r}({1:[function(e,t,n){function r(){}function o(e,t,n){return function(){return i(e,[f.now()].concat(u(arguments)),t?null:this,n),t?void 0:this}}var i=e("handle"),a=e(2),u=e(3),c=e("ee").get("tracer"),f=e("loader"),s=NREUM;"undefined"==typeof window.newrelic&&(newrelic=s);var p=["setPageViewName","setCustomAttribute","setErrorHandler","finished","addToTrace","inlineHit","addRelease"],d="api-",l=d+"ixn-";a(p,function(e,t){s[t]=o(d+t,!0,"api")}),s.addPageAction=o(d+"addPageAction",!0),s.setCurrentRouteName=o(d+"routeName",!0),t.exports=newrelic,s.interaction=function(){return(new r).get()};var m=r.prototype={createTracer:function(e,t){var n={},r=this,o="function"==typeof t;return i(l+"tracer",[f.now(),e,n],r),function(){if(c.emit((o?"":"no-")+"fn-start",[f.now(),r,o],n),o)try{return t.apply(this,arguments)}catch(e){throw c.emit("fn-err",[arguments,this,e],n),e}finally{c.emit("fn-end",[f.now()],n)}}}};a("setName,setAttribute,save,ignore,onEnd,getContext,end,get".split(","),function(e,t){m[t]=o(l+t)}),newrelic.noticeError=function(e){"string"==typeof e&&(e=new Error(e)),i("err",[e,f.now()])}},{}],2:[function(e,t,n){function r(e,t){var n=[],r="",i=0;for(r in e)o.call(e,r)&&(n[i]=t(r,e[r]),i+=1);return n}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],3:[function(e,t,n){function r(e,t,n){t||(t=0),"undefined"==typeof n&&(n=e?e.length:0);for(var r=-1,o=n-t||0,i=Array(o<0?0:o);++r<o;)i[r]=e[t+r];return i}t.exports=r},{}],4:[function(e,t,n){t.exports={exists:"undefined"!=typeof window.performance&&window.performance.timing&&"undefined"!=typeof window.performance.timing.navigationStart}},{}],ee:[function(e,t,n){function r(){}function o(e){function t(e){return e&&e instanceof r?e:e?c(e,u,i):i()}function n(n,r,o,i){if(!d.aborted||i){e&&e(n,r,o);for(var a=t(o),u=m(n),c=u.length,f=0;f<c;f++)u[f].apply(a,r);var p=s[y[n]];return p&&p.push([b,n,r,a]),a}}function l(e,t){v[e]=m(e).concat(t)}function m(e){return v[e]||[]}function w(e){return p[e]=p[e]||o(n)}function g(e,t){f(e,function(e,n){t=t||"feature",y[n]=t,t in s||(s[t]=[])})}var v={},y={},b={on:l,emit:n,get:w,listeners:m,context:t,buffer:g,abort:a,aborted:!1};return b}function i(){return new r}function a(){(s.api||s.feature)&&(d.aborted=!0,s=d.backlog={})}var u="nr@context",c=e("gos"),f=e(2),s={},p={},d=t.exports=o();d.backlog=s},{}],gos:[function(e,t,n){function r(e,t,n){if(o.call(e,t))return e[t];var r=n();if(Object.defineProperty&&Object.keys)try{return Object.defineProperty(e,t,{value:r,writable:!0,enumerable:!1}),r}catch(i){}return e[t]=r,r}var o=Object.prototype.hasOwnProperty;t.exports=r},{}],handle:[function(e,t,n){function r(e,t,n,r){o.buffer([e],r),o.emit(e,t,n)}var o=e("ee").get("handle");t.exports=r,r.ee=o},{}],id:[function(e,t,n){function r(e){var t=typeof e;return!e||"object"!==t&&"function"!==t?-1:e===window?0:a(e,i,function(){return o++})}var o=1,i="nr@id",a=e("gos");t.exports=r},{}],loader:[function(e,t,n){function r(){if(!x++){var e=h.info=NREUM.info,t=d.getElementsByTagName("script")[0];if(setTimeout(s.abort,3e4),!(e&&e.licenseKey&&e.applicationID&&t))return s.abort();f(y,function(t,n){e[t]||(e[t]=n)}),c("mark",["onload",a()+h.offset],null,"api");var n=d.createElement("script");n.src="https://"+e.agent,t.parentNode.insertBefore(n,t)}}function o(){"complete"===d.readyState&&i()}function i(){c("mark",["domContent",a()+h.offset],null,"api")}function a(){return E.exists&&performance.now?Math.round(performance.now()):(u=Math.max((new Date).getTime(),u))-h.offset}var u=(new Date).getTime(),c=e("handle"),f=e(2),s=e("ee"),p=window,d=p.document,l="addEventListener",m="attachEvent",w=p.XMLHttpRequest,g=w&&w.prototype;NREUM.o={ST:setTimeout,SI:p.setImmediate,CT:clearTimeout,XHR:w,REQ:p.Request,EV:p.Event,PR:p.Promise,MO:p.MutationObserver};var v=""+location,y={beacon:"bam.nr-data.net",errorBeacon:"bam.nr-data.net",agent:"js-agent.newrelic.com/nr-1071.min.js"},b=w&&g&&g[l]&&!/CriOS/.test(navigator.userAgent),h=t.exports={offset:u,now:a,origin:v,features:{},xhrWrappable:b};e(1),d[l]?(d[l]("DOMContentLoaded",i,!1),p[l]("load",r,!1)):(d[m]("onreadystatechange",o),p[m]("onload",r)),c("mark",["firstbyte",u],null,"api");var x=0,E=e(4)},{}]},{},["loader"]);</script> <meta name="viewport" content="width=device-width, initial-scale=1"> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js"></script> <link href='/content/public/css-core.css?v=21646015451' rel="stylesheet" type="text/css" /> <link href='/content/public/css-supporting.css?v=21660439727' rel="stylesheet" type="text/css" /> <script src="/bundles/public/coveo-dependencies.js?v=21660439727" type="text/javascript"></script> <script src="/bundles/public/jquery-features.js?v=21660439727" type="text/javascript"></script> <script src="/bundles/public/js-supporting.js?v=21660439727" type="text/javascript"></script> <script> //Global vars
var oEmailSubTimer; var dvEmailSub, dvEventSubmit, dvOssSurvey; var visitCount=0; var emailVisitCount=0;
var $jQ = jQuery.noConflict();
$ = jQuery.noConflict(); </script> <script> var isMobile = window.matchMedia("only screen and (max-width: 760px)").matches; </script> <script> var isTablet = window.matchMedia("only screen and (max-width: 1200px)").matches; </script><script type="text/javascript"> (function() {
		var css = document.createElement('link');
		css.href = '//cdnjs.cloudflare.com/ajax/libs/font-awesome/4.1.0/css/font-awesome.min.css';
		css.rel = 'stylesheet';
		css.type = 'text/css';
		document.getElementsByTagName('head')[0].appendChild(css);
	})(); </script><script> var isMobile = window.matchMedia("only screen and (max-width: 760px)").matches; </script> <meta name="verify-v1" content="HdocqHqkIh/dBv6gbC1hYzp8AZFAws0DzzDbycC/O88=" /><script> /* Updated: 10-Jan-2018 */
var _authorName = (typeof(contentAuthor) != "undefined") ? contentAuthor : "System";
var _publishDate = (typeof(contentPublishDate) != "undefined") ? contentPublishDate: "2015-04-01";
var _contentTemplate = (typeof(contentTemplate) != "undefined") ? contentTemplate: "Undefined";

(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-202362-1', 'auto', {'allowLinker': true});
ga('require', 'displayfeatures');
ga('require', 'linker');
ga('linker:autoLink', ['simplermedia.com', 'cmswire.com']);

ga('send', 'pageview', {
  'dimension1': _authorName,
  'dimension2': _publishDate
});
ga('send', 'event', 'PageViewByAuthor', _authorName, location.pathname);
ga('send', 'event', 'PageViewByType', _contentTemplate, location.pathname); </script> <script> var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
   var gads = document.createElement("script");
   gads.async = true;
   gads.type = "text/javascript";
   var useSSL = "https:" == document.location.protocol;
   gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
   var node =document.getElementsByTagName("script")[0];
   node.parentNode.insertBefore(gads, node);
  })();
	
googletag.cmd.push(function() {
  //consoleMsg('DFP - Command queue processing is starting...');
  googletag.pubads().addEventListener('slotRenderEnded', function(event) {
          var $slotName = event.slot.getAdUnitPath();
	  //consoleMsg('DFP - Slot: ' +$slotName +' with ID: \'' + event.slot.getSlotElementId() +'\' rendered. Setting CSS.');
          updateDFPSlots();
  });
});
function updateDFPSlots() {
  $jQ("iframe[id*='google_ads_iframe_']").not('[id*=__hidden__]').each(function(key,val) {
    var $slotName = $jQ(this).attr('name');
    var $cssHref = window.location.protocol +'//' +window.location.hostname + $jQ('link[href*=css-core]').attr('href');
    var $contents = '';
    try { $contents = $jQ(this).contents(); } catch (e) {}
    if($contents !== '') {
               var $head = $contents.find("head");
		var $links = $contents.find("link");
		if($links.length < 1) { 
		  consoleMsg('DFP - Post processing slot: ' +$slotName);
		  $head.append($jQ("<link/>", {rel: "stylesheet",href: $cssHref,type: "text/css" }));
		  $jQ(this).contents().find("a").attr("target","_blank");  
		  if($slotName.indexOf('Article-Base_600x200') > 0) {
			$jQ(this).css({'width':'100%'});
		  }
		}
	}
  });
}
function resizeIframe(obj) {
  obj.style.height = 0;
  obj.style.height = obj.contentWindow.document.body.scrollHeight + 'px';
}
$jQ(document).ready(function() { setTimeout(function(){ updateDFPSlots(); }, 1300); });
$jQ(document).ready(function() { setTimeout(function(){ updateDFPSlots(); }, 3000); }); </script> <script type="text/javascript"> function setCookieLocal(n,v,xdays) {
  var exdate=new Date();
  exdate.setDate(exdate.getDate() + xdays);
  var val=escape(v) + ((xdays==null) ? "" : ("; expires="+exdate.toUTCString()));
  document.cookie= n + "=" + val + "; path=/";
}
function getCookieLocal(name) {
  var value = "; " + document.cookie;
  var parts = value.split("; " + name + "=");
  if (parts.length == 2) {return parts.pop().split(";").shift();}
  else {return -1;}
}
var iVisitCount = getCookieLocal('VisitCount');
var iEmailVisitCount = getCookieLocal('EmailVisitCount');
var bEmailSubscribed = getCookieLocal('Newsletter_Subscribed') != -1 ? true : false;
var iLastNLPop = getCookieLocal('LastNLPop');

if(bEmailSubscribed == false && iEmailVisitCount > 0) {bEmailSubscribed = true;}
else if (window.location.href.indexOf('mkt_tok') > -1) {bEmailSubscribed = true;}
else if (document.referrer.indexOf('go.simplermedia.com') > -1) {bEmailSubscribed = true;}
var bDoNLPop = bEmailSubscribed == false && (iLastNLPop < 0 || Math.floor(Date.now() / 1000) - iLastNLPop > (60*60*48));
try {console.log('Email Subscribed: ' + bEmailSubscribed +'. Last NLPop: ' +iLastNLPop +'. DoNLPop: ' +bDoNLPop);} catch(e) {}

//NL Prompt
function showNewsletterPrompt(delaySecs, dfpClick, v) {
  if(bEmailSubscribed == false && bDoNLPop) {
    setCookieLocal('LastNLPop', Math.floor(Date.now() / 1000), 5);
    cwc_showNewsletterDialog(delaySecs,dfpClick, v);
    _gaq.push(['_trackEvent', 'NL-Prompt', 'Display', v]);		
  }
}
jQuery(document).ready(function() {
  var pVer = '03a';
  //Disabled on 08-Jun-2016 -Fred Flinny
  //showNewsletterPrompt(0,'',pVer); 
  //jQuery('#nlp' +pVer +'_txtEmail').focus();
});

//DFP
googletag.cmd.push(function() { googletag.pubads().setTargeting('page_url', window.location.pathname.replace(new RegExp('/', 'g'), '_')); });
try {console.log('page_url: ' + window.location.pathname.replace(new RegExp('/', 'g'), '_'));} catch(e) {}
// New visitor?
if (iVisitCount > 0) { googletag.cmd.push(function() { googletag.pubads().setTargeting('NewVisitor', 'false'); }); } else { googletag.cmd.push(function() {googletag.pubads().setTargeting('NewVisitor', 'true'); }); }
// Email subscriber?
if(bEmailSubscribed) { googletag.cmd.push(function() { googletag.pubads().setTargeting('SubEmail', 'true'); }); } else { googletag.cmd.push(function() { googletag.pubads().setTargeting('SubEmail', 'false'); }); } </script><script type="text/javascript"> var disqus_domain = 'disqus.com';
var disqus_shortname = 'cmswire'; </script><link rel="alternate" type="application/rss+xml" title="CMSWire - All News" href="https://feeds2.feedburner.com/CMSWire" /> <link rel="alternate" type="application/rss+xml" title="CMSWire - Upcoming Events" href="https://feeds2.feedburner.com/CMSWire-Events" /> <link rel="me" type="text/html" href="https://plus.google.com/+CMSWire" /> <link rel="me" type="text/html" href="https://twitter.com/CMSWire" /> <script type='text/javascript'> (function(c,h,a,f,i,e){c[a]=c[a]||function(){(c[a].q=c[a].q||[]).push(arguments)};
 c[a].a=i;c[a].e=e;var g=h.createElement("script");g.async=true;g.type="text/javascript";
 g.src=f+'?aid='+i;var b=h.getElementsByTagName("script")[0];b.parentNode.insertBefore(g,b);
 })(window,document,"rtp","//sjrtp4-cdn.marketo.com/rtp-api/v1/rtp.js","simplermediagroup");
 
rtp('send','view');
rtp('get', 'campaign',true); </script> <script src="https://load.sumome.com/" data-sumo-site-id="8be930c765939695646a5aef3ca375134ac2e81704447f5f11b50cc837554e16" async="async"></script><script> !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
fbq('init', '1754830201503161'); // Insert your pixel ID here.
fbq('track', 'PageView'); </script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1754830201503161&ev=PageView&noscript=1"
/></noscript> <link href="/public/common/dynamic.css?ids=450f2610-b62c-4c8b-a924-0764a0212363" rel="stylesheet" type="text/css" /> <script type="text/javascript"> googletag.cmd.push(function () {
googletag.defineSlot('/1003060/Article-Base_600x200', [600, 200], 'div-gpt-ad-1336852434508-1').addService(googletag.pubads());
googletag.defineSlot('/1003060/Inline-300x250--01', [300, 250], 'div-gpt-ad-1336852434508-3').addService(googletag.pubads());
googletag.defineSlot('/1003060/CW_JS-01', [10, 10], 'div-gpt-ad-1352353012906-0').addService(googletag.pubads());
googletag.defineSlot('/1003060/Article-Base_300x250', [300, 250], 'div-gpt-ad-1336852434508-0').addService(googletag.pubads());
googletag.defineSlot('/1003060/Popup-Poll', [420, 540], 'div-gpt-ad-1336852434508-6').addService(googletag.pubads());
googletag.defineSlot('/1003060/Article-Top_468x15', [468, 15], 'div-gpt-ad-1336852434508-2').addService(googletag.pubads());

if (typeof(isMobile) == "undefined" || isMobile === false) {
googletag.defineSlot('/1003060/Sitewide-Top_728', [728, 90], 'div-gpt-ad-1336852434508-10').addService(googletag.pubads());
}

if (typeof(isTablet) == "undefined" || isTablet === false) {
googletag.defineSlot('/1003060/Side-Right_300x600', [300, 600], 'div-gpt-ad-1336852434508-8').addService(googletag.pubads());
}

googletag.pubads().collapseEmptyDivs();

googletag.pubads().enableSingleRequest();

googletag.pubads().setTargeting("tags", ["open_source","information_management","osi","eim","foss","foss_update","open_source_software","open_source_technologies"]);
            googletag.enableServices();
        }); </script> <link rel="schema.dcterms" href="https://purl.org/dc/terms/"> <meta name="dcterms.language" content="en-us" /> <meta name="dcterms.format" content="text/html" /> <meta name="dcterms.publisher" content="Simpler Media Group, Inc." /> <meta name="dcterms.rights" content="Copyright 2003-2018 Simpler Media Group, Inc." /> <meta property="fb:app_id" content="131721606912999" /> <meta property="og:site_name" content="CMSWire.com" /> <meta property="og:title" content="Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us" /> <meta property="og:language" content="en-US" /> <meta property="og:country-name" content="USA" /> <link rel="start" href="https://www.cmswire.com/" title="Home" /> <script> jQuery(document).ready(function () {
            consoleMsg('Site root: http://www.cmswire.com/ ');
            consoleMsg('Template: article ');
            //fix according  feature/OT-1376-Update_Auto_Redirect_to_Homepage_to_a_Page_Refresh
            setRF();
        }); </script> </head> <body class="article"> <div id="parsely-root" style="display: none"> <div id="parsely-cfg" data-parsely-site="cmswire.com"></div> </div> <script> (function(s, p, d) { 
  var h=d.location.protocol, i=p+"-"+s, 
      e=d.getElementById(i), r=d.getElementById(p+"-root"), 
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net" 
      :"static."+p+".com"; 
  if (e) return; 
  e = d.createElement(s); e.id = i; e.async = true; 
  e.src = h+"//"+u+"/p.js"; r.appendChild(e); 
})("script", "parsely", document); </script><div id="fb-root"></div> <script> (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=131721606912999";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk')); </script><script src="https://apis.google.com/js/platform.js" async defer></script><script async src="//platform.linkedin.com/in.js" type="text/javascript"></script><script> !function (d, s, id) { var js, fjs = d.getElementsByTagName(s)[0], p = /^http:/.test(d.location) ? 'https' : 'https'; if (!d.getElementById(id)) { js = d.createElement(s); js.id = id; js.src = p + '://platform.twitter.com/widgets.js'; fjs.parentNode.insertBefore(js, fjs); } }(document, 'script', 'twitter-wjs'); </script> <div class="mobile-menu"> <ul> <li><a href='/'>Home</a></li> <li class="with-subitems"> <a href='javascript:void(0);' title='Channels'>Channels</a> <ul> <li><a href="/customer-experience/">Customer Experience</a></li> <li><a href="/digital-experience/">Digital Experience</a></li> <li><a href="/digital-workplace/">Digital Workplace</a></li> <li><a href="/digital-marketing/">Digital Marketing</a></li> <li><a href="/content-marketing/">Content Marketing</a></li> <li><a href="/marketing-automation/">Marketing Automation</a></li> <li><a href="/web-cms/">Web CMS</a></li> <li><a href="/sharepoint-office-365/">SharePoint &amp; Office 365</a></li> <li><a href="/information-management/">Information Management</a></li> </ul> </li> <li><a href='/white-papers/'>White Papers</a></li> <li><a href='/events/webinars/'>Webinars</a></li> <li><a href='/d/'>Software Directory</a></li> <li><a href='/events/' title='Events Calendar'>Events Calendar</a></li> <li><a href='/about-us/' title='About Us'>About Us</a></li> <li><a href='/about-us/editorial-calendar/'>Editorial Calendar</a></li> <li><a href='/about-us/#contact' title='Contact'>Contact Us</a></li> <li><a href='http://www.simplermedia.com/mediakit/v1-00/titles/cmswire/' target='_blank' title='Advertise Here'>Advertise Here</a></li> </ul> </div><div class="wrapper"> <div id="header"> <div class="container"> <div class="row top-header hidden-sm hidden-xs hidden-md"> <div class="col-md-3"> <ul class="social-links"> <li> <a href='https://twitter.com/CMSWire' class='twitter' target='_blank' title='Twitter'> <i class="fa fa-twitter"></i> </a> </li> <li> <a href='https://www.linkedin.com/company/cmswire' class='linkedin' target='_blank' title='LinkedIn'> <i class="fa fa-linkedin"></i> </a> </li> <li> <a href="https://facebook.com/CMSWire" class='facebook' target='_blank'> <i class="fa fa-facebook"></i> </a> </li> <li> <a href='https://plus.google.com/+CMSWire' class='googleplus' target='_blank' title='Google+'> <i class="fa fa-google-plus"></i> </a> </li> <li> <a href="https://feeds.feedburner.com/CMSWire" class='rss' target='_blank' title='RSS Feed'> <i class="fa fa-rss"></i> </a> </li> </ul> </div> <div class="col-md-4 desktop-fix"> <div class="subscribe"> <form method="post" id="frmESub_Header" name="frmESub_Header" action="#null" onsubmit="return validateNLSubscribe('#txtEmlSub_Header', '#frmESub_Header', 'header');"> <input id="txtEmlSub_Header" type="text" placeholder="Enter email address..." /> <input type="button" value="Subscribe" onclick="$('#frmESub_Header').submit();return false;" /> </form> </div> </div> <div class="col-md-5 text-right hidden-sm hidden-xs hidden-md"> <ul class="secondary-menu"> <li><a href='/about-us/' target='_parent' title='About Us'>About Us</a></li> <li><a href='/about-us/editorial-calendar/' target='_parent' title='Editorial Calendar'>Editorial Calendar</a></li> <li><a href='/about-us/#contact' target='_parent' title='Contact'>Contact Us</a></li> <li><a href='https://www.simplermedia.com/brands/cmswire/' target='_blank' title='Advertise Here'>Advertise Here</a></li> </ul> </div> </div> <div class="row bottom-header"> <div class="col-md-3 logo-container"> <div class="mobile-menu-trigger"></div> <div class="mobile-search-trigger"></div> <a href='/'> <img src="/~/media/346f68a07ac545a09971abfdb558e17a.png" srcset="/~/media/6b7896af281a4c20919737b0fad23ff2.png?mw=346&amp;mh=58&amp;hash=379B0B2D75C965C173FF218512ADA4707EC98E8B 2x" alt="CMSWire"> </a> </div> <div class="col-md-9 desktop-fix hidden-sm hidden-xs hidden-md"> <ul class="main-menu" id="myMenuAsyc"> <li top-menu-item> <a href='javascript:void(0);'>Channels</a> </li> <li top-menu-item> <a href='javascript:void(0);'>Featured Products</a> </li> <li top-menu-item> <a href='/white-papers/'>White Papers</a> </li> <li top-menu-item> <a href='/events/webinars/'>Webinars</a> </li> <li top-menu-item> <a href='/d/'>Software Directory</a> </li> <li top-menu-item> <a href='/events/'>Events</a> </li> </ul> <script> $jQ.get("/fragments/mainmenu.aspx", function (data, status) {
        $jQ("#myMenuAsyc").replaceWith(data);
        $jQ(".side-menu li a").hover(function () {
            var t = $(this).attr("rel");
            var container = $jQ(this).closest(".container");
            container.find("a").removeClass("active");
            $jQ(this).addClass("active");
            container.find(".tab-content").hide();
            $jQ(t).show();
            return false;

        });

        $jQ("li[top-menu-item]").hover(function () {
            var a = $jQ(this).find(".side-menu li a");
            a.removeClass("active");
            $jQ(a[0]).addClass("active");
            var container = $jQ(a[0]).closest(".container").find(".tab-content").hide();
            var t = $jQ(a[0]).attr("rel");
            $jQ(t).show();
        });
    }); </script> <ul class="main-menu"> <li class="search-site"> <div id="top-search-box"> <div class="CoveoSearchBox" data-activate-omnibox="true"></div> </div> </li> </ul> <script type="text/javascript"> //Coveo
    jQuery(function () {

        var customEndpoint = new Coveo.Rest.SearchEndpoint({
            restUri: 'http://www.cmswire.com/coveo/rest'
        })

        $jQ('#top-search-box').coveo('initSearchBox', 'http://www.cmswire.com/search/');
        $jQ('#top-search-box').find('.CoveoQueryBox').addClass("search-site").attr("placeholder", "Search");
        $jQ('<div style="clear: both;"></div><span class="search-icon"><i class="fa fa-search"></i></span>').insertAfter("#top-search-box .CoveoQueryBox.search-site");

        //custom row html building with highlighting
        function buildOmniBoxForOneRow(result) {
            var t = result.Title;
            var highlighted = [];
            var last = 0;
            for (var i = 0 ; i < result.titleHighlights.length ; i++) {
                var highLight = result.titleHighlights[i];

                highlighted.push(
                    t.slice(last, highLight.offset),
                    "<span class='coveo-highlight'>",
                    t.slice(highLight.offset, highLight.offset + highLight.length),
                    "</span>");
                last += highLight.offset + highLight.length
            }
            highlighted.push(t.slice(last))
            return $jQ("<div>" + highlighted.join("") + "</div>");
        }

        function buildOmniBoxContent(arrayOfValues, populateOmniBoxObject) {
            var resultsContainer = $jQ("<div></div>")
            for (var i = 0 ; i < arrayOfValues.length ; i++) {
                
                var oneRowOfContent = buildOmniBoxForOneRow(arrayOfValues[i])
                $jQ(oneRowOfContent).addClass("coveo-omnibox-selectable")
                $jQ(oneRowOfContent).addClass("coveo-top-field-suggestion-row")
                $jQ(oneRowOfContent).attr("data-href",arrayOfValues[i].raw.sysclickableuri);
                $jQ(oneRowOfContent).on("click keyboardSelect", function () {
                    populateOmniBoxObject.clear();
                    //populateOmniBoxObject.close();
                    window.location.href = $jQ(this).attr("data-href");
                })
                resultsContainer.append(oneRowOfContent);
            }

            return resultsContainer
        }

        var searchInterface = $jQ('#top-search-box');

        searchInterface.on("populateOmniBox", function (e, populateOmniBoxObject) {
            var wordToSearch = populateOmniBoxObject.completeQueryExpression.word;
            var regexToSearch = populateOmniBoxObject.completeQueryExpression.regex;

            var deferred = $jQ.Deferred();
            populateOmniBoxObject.rows.push({ deferred: deferred });

            var myQueryBuilder = new Coveo.Ui.QueryBuilder();
            myQueryBuilder.expression.add(wordToSearch);
            myQueryBuilder.constantExpression.add("@syssource=='SmgWeb_index_Source'");
            myQueryBuilder.numberOfResults = 8;
            var myQuery = myQueryBuilder.build();
            customEndpoint.search(myQuery).done(function (response) {
                if (response.queryError) {
                    //alert(response.message);
                    deferred.resolve({ element: undefined })
                } else {
                    deferred.resolve({
                        zIndex: 100, 
                        element: buildOmniBoxContent(response.results, populateOmniBoxObject)
                    });
                }
            })
        });
    }); </script> <style> .CoveoSearchInterface {
        height: auto;
        min-height: 16px;
    }

    .search-site .CoveoSearchButton {
        display: none;
    }

    .search-site .CoveoSearchBox {
        border-radius: 0;
        height: auto;
        overflow: visible;
    }

        .search-site .CoveoSearchBox > div {
            height: auto;
            overflow: visible;
            position: relative;
        }

    .CoveoQueryBox.search-site {
        border-radius: 0;
        font-size: 14px;
        padding-left: 1px;
        padding-bottom: 1px;
        height: auto;
    }

    .search-site .coveo-query-box-clear {
        display: none !important;
    }

    #top-search-box .coveo-omnibox {
        top: 27px;
    }

    #top-search-box .coveo-omnibox-header {
        background: none repeat scroll 0 0 #e2e2e2;
        color: #666666;
    }

    #top-search-box .coveo-top-suggestion-row, #top-search-box .coveo-top-field-suggestion-row, #top-search-box .coveo-top-analytics-suggestion-row, #top-search-box .coveo-top-field-suggestion-row {
        padding: 5px 7px 5px 14px;
        height: auto;
        text-overflow: initial;
        white-space: normal;
    }

    #top-search-box .coveo-top-suggestion-header, #top-search-box .coveo-top-field-suggestion-header, #top-search-box .coveo-top-analytics-suggestion-header, #top-search-box .coveo-omnibox-result-list-header {
        padding-left: 5px;
    }
    
    #top-search-box .coveo-icon-top-field {
        display: none;
    }

    #top-search-box .coveo-omnibox .coveo-omnibox-header .coveo-text {
        padding-left: 5px;
    } </style> </div> </div> </div> </div> <script type="text/javascript"> //Coveo.
    jQuery(function () {
        Coveo.Rest.SearchEndpoint.endpoints.default = new Coveo.Rest.SearchEndpoint({
            restUri: 'http://www.cmswire.com/coveo/rest'
        });
        Coveo.$('#searchBoxMobile').coveo('initSearchBox', 'http://www.cmswire.com/search/');
        Coveo.$('#searchBoxMobile').find('.CoveoQueryBox').addClass("search-mobile-site").attr("placeholder", "Search...");
        Coveo.$('#searchBoxMobile').find('.CoveoSearchButton').addClass("mobile-search-button").text("GO");
    }); </script> <div class="mobile-search"> <div class="container"> <div class="row"> <div id="searchBoxMobile" class="col-sm-12"> <div class="CoveoSearchBox" data-activate-omnibox="true"></div> </div> </div> </div> </div> <link rel="stylesheet" href="/bundles/public/search_mobile.css?v=21660439727" /><div class="container"> <div class="row main-ad-block text-center hidden-xs"> <div class="col-sm-12 hidden-sm hidden-xs"> <div id="div-gpt-ad-1336852434508-10" class=""> <script type='text/javascript'> if (typeof (isMobile) == "undefined" || isMobile === false) {
                    try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-10');
});
} catch (e) {
};
                } </script> </div> </div> </div> <div class="row"> <div class="col-md-12 hidden-sm hidden-xs"> <ul class="topics"> <li>Channels</li> <li><a href='/customer-experience/'>Customer Experience</a></li> <li><a href='/digital-experience/' title='Digital Experience'>Digital Experience</a></li> <li><a href='/tag/dam/'>DAM</a></li> <li><a href='/digital-workplace/'>Digital Workplace</a></li> <li><a href='/sharepoint-office-365/'>SharePoint & Office 365</a></li> <li><a href='/web-cms/' title='Web CMS'>Web CMS</a></li> <li><a href='/mobile-enterprise/' title='Mobile Enterprise'>Mobile</a></li> <li><a href='/document-management/'>Document Mgt</a></li> </ul> </div> </div> <div class="row"> <div class="col-md-8"> </div> <div class="content-body col-md-8 col-sm-6 col-xs-12"> </div> <div class="col-md-4 col-sm-6 hidden-xs"> </div> </div> <div class="row"> <div> <div class="col-md-12"> <h1> Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us </h1> </div> <div class="content-body col-md-8 col-sm-6 col-xs-12"> <div class="article-author"> <img src="/~/media/c8dd8494bde24d8799f1b51442443ff0.png?w=200&amp;h=200&amp;as=1&amp;hash=6004182800F7923AFA4C7A281E85DC8BFBCE21E3" alt="David Roe" width="100" height="100" class="author-avatar" /> <p> By <span class="author"><a href="/author/david-roe/" title="David Roe's profile" rel="author">David Roe</a></span> <span class="separator">|</span> <em>Feb 2, 2018</em> </p> <p class="category hidden-sm hidden-xs"> CHANNEL: <a href="/digital-workplace/">Digital Workplace</a> </p> <a href="https://twitter.com/druadh20" class="twitter-follow-button" data-show-count="true" data-show-screen-name="false"></a> </div> <div class="article-smallad"> <div id="div-gpt-ad-1336852434508-2" class=""> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-2');
});
} catch (e) {
}; </script> </div> </div> <div class="article-body"> <figure class="image-figure image-figure_featured-image article-vert insidevert1"> <img src="/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg?mw=320&amp;mh=240&amp;hash=95349B5BA219BB2A43EFDAE3F00D11C83647F767" srcset="/~/media/9208cefbb3f34d9c9622df8e22dabff1.jpg?mw=640&mh=480&hash=95349B5BA219BB2A43EFDAE3F00D11C83647F767 2x" alt="Two developers at their PCs collaborating on an open source development project" class="block " /> <figcaption> <span class="photo-credit"> <i class="fa fa-camera"></i> PHOTO: <a href="https://www.shutterstock.com/download/confirm/426504676" title="Shutterstock" style="color: #888; text-decoration: none;" rel="nofollow">Shutterstock</a> </span> </figcaption> </figure> <p>The Open Source Initiative (OSI) is celebrating its 20th birthday in 2018. The actual 20th anniversary is Feb.3rd, but there will be a number of notable events over the year to mark the occasion, including the launch of Opensource.net, a global network of open source peers to enable users to exchange ideas and create solutions. It is hoped that the network will contribute to the next 20 years of open source development.</p> <p>The open source label was <a href="https://opensource.org/" target="_blank">created at a strategy session</a> held on Feb. 3rd, 1998 in Palo Alto, Calif. That same month, the Open Source Initiative (OSI) was founded as a general educational and advocacy organization to raise awareness and adoption for the open development process.</p> <p>Open source projects of the first decade were predominantly replacements for off-the-shelf products, while in the second decade they were increasingly components of larger solutions. So what is going to happen in the third decade of open source? To find out we contacted many open source developers and companies that describe themselves as open source and asked them what they think will happen in the next 20 years.</p> <h2>1. Blockchain </h2> <p>Dirk Hohndel is Palo Alto, California based <a href="https://www.vmware.com" target="_blank">VMware&rsquo;s chief open source officer</a>. VMWare, which was bought by Dell, actively engages with the open source community through contributions to existing projects as well as developing, and releasing new open source projects and initiatives. He offered several predictions about the future.</p><div id="div-gpt-ad-1336852434508-3" class="article-vert insidevert2"> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-3');
});
} catch (e) {
}; </script> </div> <p>Blockchain technologies, he said, are presently infiltrating financial markets, but hold the potential to disrupt a host of business processes across industries. Blockchain is unique because it uses untrustworthy communication channels to create trust between parties that otherwise wouldn&rsquo;t necessarily cooperate with each other. Specifically, expect the Hyperledger Project, driven by The Linux Foundation, to make an impact in 2018.</p> <p><strong>Related Article: <a href="https://www.cmswire.com/information-management/how-hyperledger-is-accelerating-blockchain-for-the-enterprise/" title="How Hyperledger is Accelerating Blockchain for the Enterprise">How Hyperledger is Accelerating Blockchain for the Enterprise</a></strong></p> <h2>2. Internet of Things (IoT)</h2> <p>The two major challenges with IoT are security and management for a massive amount of endpoints. Hohndel shared that in order to manage an IoT environment, it is necessary to have a de facto standard to communicate between local gateways, edge devices, and sensors.&nbsp; Expect open source development to be a key part of any software stack that enables IT to manage and secure an IoT environment regardless of who the vendor is.</p> <h2>3. The C-Suite Joins the Open Source Movement</h2> <p>As the C-suite better understands how open source plays a significant role in the management, compliance, and security in the enterprise, more and more companies will proactively participate in the open source community to help drive strategies and priorities. </p> <h2>4. Boring But Unpredictable</h2> <p>Hohndel points out that Linux is now 26 years old and, to quote its inventor Linus Torvalds, it is &ldquo;incredibly boring.&rdquo; Linux updates are released every two months and are entirely predictable, reliable, and deeply rooted in the idea of incremental progress. Although there is no controlling entity, roadmap, or rollout plan, all the major open source projects like Linux, Kubernetes, and OpenStack are well run, and progress is consistent and predictable. On the flipside, the fascinating part about open source is that there are more than 63 million projects, and the depth and breadth of that work is significant. </p> <h2>5. Technology Collaboration</h2> <p>Abby Kearns is executive director at the <a href="https://www.cloudfoundry.org/foundation/" target="_blank">San Francisco based Cloud Foundry Foundation</a>. She believes that Kubernetes has made it possible to use and deploy containers at scale enabling enterprises to become cloud native. Open source offers companies an unprecedented opportunity to collaborate in new and innovative technologies - putting them in the driver&rsquo;s seat. </p> <h2>6. Technology Innovation</h2> <p>Red Hat a Raleigh, North Carolina based multinational providing open-source software products to the enterprise community. Nick Hopman is its <a href="https://www.redhat.com/en" target="_blank">senior director for emerging technology practices</a>. He said that he sees open source as much more than just a process to develop and expose technology,&nbsp;</p> <p>&ldquo;I see it as a catalyst to drive change in every facet of society, including government, policy, medical diagnostics, process re-engineering. All these things and more can use open principles that have been perfected through the experiences of open source software development to create communities that drive change and innovation.&rdquo;</p> <h2>7. Easy Open Source</h2> <p>Johm Zannos is GM and CRO at <a href="http://www.inocybe.com/" target="_blank">Montr&eacute;al, Canada based Inocybe</a>, which provides open networking solutions. He said that telecom and cable companies are adopting open source in networking to help tackle the challenge of increasing revenue, pace of innovation and reducing the cost of deploying new revenue generating services. Over the next three years, the challenge will be making open source easier to consume and available to an even broader universe of users. </p> <h2>8. Open Source CMS</h2> <p>Olivier Deneef is Client Service Director at <a href="https://www.the-reference.com/en" target="_blank">The Reference, a Belgian Web Agency </a>founded in 1993 that works at the intersection of cutting edge tech and marketing. He said that Open&nbsp;Source&nbsp;CMS systems have taken a very important step forward in their evolution by supporting PaaS (Platform-as-a-Service) solutions. This is what Acquia is doing on Drupal and Umbraco is offering by itself, he said. </p> <p>&ldquo;This seems to combine the best of both worlds: enjoying the benefits of an open community, but eliminating the risks related to it as much as possible. Additionally, there is a strong evolution towards headless CMS systems and API driven ecosystems (best of breed).&nbsp; Whereas in the past, large enterprises typically preferred a closed environment [best-of-breed] is replacing that]&rdquo;.</p> <p><strong>Related Article: <a href="https://www.cmswire.com/web-cms/13-headless-cmss-to-put-on-your-radar/" title=" 13 Headless CMSs to Put on Your Radar">13 Headless CMSs to Put on Your Radar</a></strong></p> <h2>9. Open Source Standard?</h2> <p>Darryl Levesque, Director of Technology Solutions at&nbsp;<a href="https://www..kanatek.com/about-us/darryl-levesque/" target="_blank">Ontario, Canada based Kanatek</a>, thinks&nbsp;that the open source market is maturing and as it gains mainstream attention and implementation (small to medium businesses) the user community will strengthen it, making it a more robust solution. As open source code becomes more robust, there will also be increased adoption among enterprise businesses. The increase in popularity will eventually&nbsp;lead&nbsp;to open source becoming a de facto standard. </p> <h2>10. Security</h2> <p> Jeff Luszcz, Vice President of Product Management at <a href="https://www.flexera.com/" target="_blank">Schaumburg, Illinois based Flexera</a>, a developer of software security products, says that there will be more massive hacks due to vulnerable open source and third-party components. &ldquo;Once an open source component is selected, it&rsquo;s often ignored and forgotten as development moves on to new features, meaning these components often contain known security vulnerabilities or conflicts with a company&rsquo;s open source license policy. These forgotten components age out, and become attack vectors as vulnerabilities are discovered in them."</p> <h2>11. Communities of Communities </h2> <p>Mountain View, <a href="http://www.dremio.com" target="_blank">California based Dremio</a> is an open source, self-service data analytics company and Jacques Nadeau is its founder and CTO. According to him, as open source projects have matured, a newer generation of projects have emerged that bridge multiple projects to serve a common interest. The benefit to projects are a more efficient way to manage data analytics in memory, and to more easily exchange data between processes. </p> <h2>&nbsp;12. Diversity In Project Committees </h2> <p>He points out that there are two prevailing models for open source software development &mdash; a benevolent and a consensus driven committee. While each approach has its pros and cons, the philosophy of the consensus model has always been that a diverse collection of interest&rsquo;s can produce a common set of goals through dialog and established process. Some projects are not as diverse as they could be, and there is an opportunity for us to do better in terms of ensuring a wide range of points of view. He said that he believes some of these groups such as the Apache Foundation will revisit the structure of their projects to ensure greater diversity.</p> <h2>&nbsp;13. Project Sponsorship </h2> <p>Developing software is a complex and expensive process that requires significant funding and commitment by participants, more than some organizations are able undertake on their own. He said he expects to see more companies from common industries or use cases come together to devote financial and staffing resources to support open source projects that are mutually beneficial to all parties.</p> <h2>14. Open Source-as-a-Service</h2> <p>Rackspace is a <a href="http://www.rackspace.com" target="_blank">Windcrest, Texas based cloud management company</a>. Its senior director and general manager for OpenStack Private Cloud Bryan Thompson. &nbsp;He said they will be focusing their efforts outside of disparate open source technologies and honing in on operationalizing and standardizing those technologies to work better together, giving customers a more seamless experience when consuming open source technologies. We will also see customers begin to consume open source as-a-service rather than go it alone or deploy individual solutions.&nbsp;</p> <h2>15. Business Models</h2> <p>Karthik Ramasamy is <a href="https://streaml.io" target="_blank">co-founder at San Francisco based Streamlio</a>. He sees the third deacde of open source being dominated by the search for viable business models. The first two decades of open source saw an extended search for viable business models, without a clear answer emerging. 2017 showed signs of potential alternatives showing repeatable success, but there is still more iteration ahead. The next few years will see experimentation and refinement of business models, including both evolutionary hybrids and new models that more directly reward open source contributors and not only commercial entities.</p> <h2>16. Modular development</h2> <p>Jonathan Cowperthwait is the<a href="https://www.npmjs.com/" target="_blank"> VP of marketing at npm</a>, which was founded in Oakland, California. It maintains the npm package manager for JavaScript and hosts the world&rsquo;s largest software registry. He said that Modular development is and will be the wave of the future. &ldquo;Looking at just the last three or four years, every major front-end web framework is now distributed through an open source package registry,&rdquo; he said. As a result, it is going to be impossible to prevent writing code with no open source dependencies, but enterprises won&rsquo;t really unleash their developers until they can ensure its safe.&nbsp;<br> <br> <br> </p> </div> <div class="social-bar"> <div class="addthis_sharing_toolbox"></div> <div class="break visible-xs"></div> <div class="widget-share comments-widget"> <img src="/Areas/Public/Content/images/comments-icon.png" alt="Comments"> <a href="#comments" data-disqus-identifier="0df6b9489717464fa6a30e640311cce9">0 Comments</a> </div> </div> <div id="div-gpt-ad-1336852434508-1" class=""> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-1');
});
} catch (e) {
}; </script> </div> <div class="tabs articles-tabs hidden-sm hidden-xs"> <ul class="tabs-menu"> <li><a href="#top-articles">Top Articles</a></li> <li><a href="#related-articles">Related Articles</a></li> <li><a href="#recent-comments">Recent Comments</a></li> </ul> <div id="top-articles"> <ul> <li><a href="/internet-of-things/industrial-iot-what-it-is-and-the-trends-driving-it-in-2018/">Industrial IoT: What It is and the Trends Driving It in 2018</a></li> <li><a href="/digital-workplace/a-look-at-the-top-workplace-tools-by-adoption/">A Look at the Top Workplace Tools by Adoption</a></li> <li><a href="/digital-workplace/the-missing-link-for-digital-transformation-success-people/">The Missing Link for Digital Transformation Success? People</a></li> <li><a href="/digital-workplace/what-does-employee-experience-really-mean/">What Does Employee Experience Really Mean?</a></li> <li><a href="/information-management/9-ways-to-jumpstart-your-gdpr-compliance-program/">9 Ways to Jumpstart Your GDPR Compliance Program</a></li> </ul> </div> <div id="related-articles"> <ul> <li><a href="/digital-workplace/want-to-attract-top-talent-remember-the-golden-rule/" title="Want to Attract Top Talent? Remember the Golden Rule">Want to Attract Top Talent? Remember the Golden Rule</a></li> <li><a href="/digital-workplace/the-missing-link-for-digital-transformation-success-people/" title="The Missing Link for Digital Transformation Success? People">The Missing Link for Digital Transformation Success? People</a></li> <li><a href="/digital-workplace/could-the-iphone-have-been-invented-in-todays-digital-workplace/" title="Could the iPhone Have Been Invented in Today&#39;s Digital Workplace?">Could the iPhone Have Been Invented in Today&#39;s Digital Workplace?</a></li> <li><a href="/digital-workplace/launching-a-new-system-this-is-the-only-metric-that-matters/" title="Launching a New System? This Is the Only Metric That Matters">Launching a New System? This Is the Only Metric That Matters</a></li> <li><a href="/digital-workplace/5-symptoms-of-poor-office-365-collaboration-and-how-to-fix-them/" title="5 Symptoms of Poor Office 365 Collaboration and How to Fix Them">5 Symptoms of Poor Office 365 Collaboration and How to Fix Them</a></li> </ul> </div> <div id="recent-comments"> <div id="footer-commented-on"></div> <script type="text/javascript" src="https://cmswire.disqus.com/recent_comments_widget.js?num_items=5&amp;hide_avatars=0&amp;avatar_size=24&amp;excerpt_length=150"></script> </div> </div> <div class="row useful-article hidden-sm hidden-xs"> <div class="col-md-6"> <div class="box gray"> <div class="title-header mb20"> <div class="h2">Useful Content?</div> </div> <div class="mb15"> <div class="addthis_toolbox addthis_20x20_style"> <a class="addthis_button_email email-this" style="float:left;"> <img src="/Areas/Public/Content/images/email-icon.png" class="v-middle" alt="Email This" style="margin-right:10px;" />Email This </a> <a class="addthis_button_stumbleupon" style="float:left;"> <img src="/Areas/Public/Content/images/stumbleupon-icon.png" alt="Stumble This" class="v-middle" style="width:24px;height:24px;margin-right:10px;" />Stumble This </a> </div> <br clear="all" /> </div> <div class="mb15"> <a href="https://twitter.com/cmswire" class="twitter-follow-button">Follow @CMSWire</a> </div> <p class="tags"> <strong>Tags</strong> <a href="/tag/eim/" rel="tag">eim</a>, <a href="/tag/foss/" rel="tag">foss</a>, <a href="/tag/foss-update/" rel="tag">foss update</a>, <a href="/tag/information-management/" rel="tag">information management</a>, <a href="/tag/open-source/" rel="tag">open source</a>, <a href="/tag/open-source-software/" rel="tag">open source software</a>, <a href="/tag/open-source-technologies/" rel="tag">open source technologies</a>, <a href="/tag/osi/" rel="tag">osi</a> </p> </div> </div> <div class="col-md-6 text-center"> <div id="div-gpt-ad-1336852434508-0" class=""> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-0');
});
} catch (e) {
}; </script> </div> </div> </div> <div class="spacer">&nbsp;</div> <a name="comments"></a> <script type="text/javascript"> function disqus_config() {
        this.callbacks.onNewComment = [function () { _nct.push(['_trackEvent', 'comment']); }];
    } </script> <div id="comments"></div> <div id="disqus_thread"></div> <script type="text/javascript"> var disqus_identifier = '0df6b9489717464fa6a30e640311cce9';
    var disqus_title = 'Open Source&#39;s Twentieth Anniversary: And Where the Next Twenty Years Will Take Us'; </script> <script type="text/javascript" src="https://cmswire.disqus.com/embed.js"></script> <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript=cmswire">comments powered by Disqus.</a></noscript> <div class="box gray hidden-sm hidden-xs"> <div class="title-header"> <div class="h2">Resources</div> </div> <ul class="events-list"> <li> <a href='https://www.dwexperience.com/2018/' target='_blank' title='Digital Workplace Conference 2017'>Digital Workplace Conference</a><br> <p></p> </li> <li> <a href='https://www.dxsummit.com/' target='_blank' title='DX Summit'>Digital Experience Conference</a><br> <p></p> </li> <li> <a href='/d/document-management-software-c000018' target='_blank' title='Document Management Software List'>Document Management Software</a><br> <p></p> </li> <li> <a href='/cms/web-cms/7-rules-for-selecting-the-right-content-management-system-023026.php' target='_blank' title='7 Rules for Selecting the Right Content Management System'>How to Select a Web CMS</a><br> <p></p> </li> <li> <a href='https://www.cylogy.com' target='_blank'>Sitecore Consultant</a><br> <p></p> </li> <li> <a href='https://www.cmswire.com/digital-workplace/what-the-heck-is-a-digital-workplace-anyway/' title='What is the Digital Workplace?'>What is the Digital Workplace?</a><br> <p></p> </li> </ul> </div> <div class="box gray"> <div class="title-header mb20"> <p class="view-more-events hidden-sm hidden-xs"><a href="/events/">View All Events</a> <a href="/events/#add-event">Add Your Event</a> <a href="">Events RSS</a></p> <div class="h2">Featured Events</div> </div> <ul class="events-list with-date without-border tk-museo-sans"> <li> <span class="date">Feb <strong>13</strong></span> <a href="https://bit.ly/2DjCDtH">[CMSWire Webinar] Hyper-Personalize Your Customer Experience with Big Data and AI</a> </li> <li> <span class="date">Feb <strong>20</strong></span> <a href="https://bit.ly/2DUhbM4">[CMSWire Webinar] ​Improving Customer Experience: Top Task Identification</a> </li> <li> <span class="date">Mar <strong>5</strong></span> <a href="/events/conference/gartner-data-and-analytics-summit-2018/">Gartner Data and Analytics Summit 2018</a> </li> <li> <span class="date">Mar <strong>19</strong></span> <a href="/events/conference/ibm-think-las-vegas-2018/">IBM Think Las Vegas 2018</a> </li> <li> <span class="date">Apr <strong>30</strong></span> <a href="/events/conference/collision-new-orleans-2018/">Collision New Orleans 2018</a> </li> <li> <span class="date">May <strong>8</strong></span> <a href="/events/conference/forresters-digital-transformation-forum-chicago-2018/">Forrester&#39;s Digital Transformation Forum Chicago 2018</a> </li> <li> <span class="date">Jun <strong>18</strong></span> <a href="/events/conference/digital-workplace-experience-2018/">Digital Workplace Experience 2018</a> </li> </ul> </div> </div> </div> <link rel="stylesheet" href="/bundles/public/articlecontent.css" /> <script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.js"></script> <script src="/Areas/Public/Content/js/jquery.fancybox.js" type="text/javascript"></script> <script> jQuery(document).ready(function () {
        jQuery(".fancyBoxImage").wrap(function () {
            return "<a class='fancyBoxLink' href='" + $jQ(this).attr("src") + "'></a>";
        });
        jQuery(".fancyBoxLink").each(function () {

            //to get full size image from sitecore we need to remove w= and h= paramenter from image src
            var fullImageSrc = $jQ(this).attr("href")
                .replace("&w=", "&ow=")
                .replace("?w=", "?ow=")
                .replace("&h=", "&oh=")
                .replace("?h=", "?oh=");

            jQuery(this).fancybox({
                fitToView: false,
                closeBtn: true,
                scrolling: 'yes',
                href: fullImageSrc
            });
        });
    }); </script> <div class="col-md-4 col-sm-6 hidden-xs article-side-wrap"> <div id="div-gpt-ad-1336852434508-8" class="article-side-300x600"> <script type='text/javascript'> if (typeof (isTablet) == "undefined" || isTablet === false) {
                    try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-8');
});
} catch (e) {
};
                } </script> </div> </div> </div> </div><div class="desktop-footer hidden-sm hidden-xs"> <div class="container"> <div class="row"> <div class="col-md-4"> <div class="group"> <div class="h4">About Us</div> <p>CMSWire is a leading, native digital publication produced by <a href="https://www.simplermedia.com/" target="_blank">Simpler Media Group, Inc</a>. We provide articles, research and events for sophisticated professionals driving digital customer experience strategy, evolving the digital workplace and creating intelligent information management practices. The CMSWire team produces 450+ authoritative articles per quarter for our 750,000 community members. <a href="/newsletter/sign-up/">Join us as a subscriber</a>.</p> <p><a href="/about-us/">Read more</a> about us or learn how to <a href="https://www.simplermedia.com/brands/cmswire/" target="_blank">advertise here</a>. We also have a <a href="/advisory-board/">Reader Advisory Board</a>.</p> <strong>More:</strong> <p><a href="/about-us/editorial-calendar/">Monthly Editorial Calendar</a> <br /> <a href="/about-us/submission-guidelines/" target="_parent">Article Submission Guidelines</a><br /> <a href="https://www.dwexperience.com/" title="Digital Workplace Experience conference">DW Experience Conference</a><br /> <a href="https://www.dxsummit.com/" title="Digital Experience Summit">DX Summit Conference</a><br /> <a href="https://www.simplermedia.com/brands/cmswire/" target="_blank">Advertiser Media Kit</a><br /> <a href="/press-releases/" target="_parent">Press Releases</a> </p> </div> <div class="group"> <div class="h4">Stay In the Loop</div> <ul class="social-list"> <li> <a href='https://twitter.com/CMSWire' class='twitter' target='_blank' title='Twitter'> <i class="fa fa-twitter"></i> </a> </li> <li> <a href='https://www.linkedin.com/company/cmswire' class='linkedin' target='_blank' title='LinkedIn'> <i class="fa fa-linkedin"></i> </a> </li> <li> <a href="https://facebook.com/CMSWire" class='facebook' target='_blank'> <i class="fa fa-facebook"></i> </a> </li> <li> <a href='https://plus.google.com/+CMSWire' class='googleplus' target='_blank' title='Google+'> <i class="fa fa-google-plus"></i> </a> </li> <li> <a href="https://feeds.feedburner.com/CMSWire" class='rss' target='_blank' title='RSS Feed'> <i class="fa fa-rss"></i> </a> </li> </ul> </div> <div class="group"> <div class="h4">Get Our Newsletter</div> <form method="post" id="frmESub_Footer" name="frmESub_Footer" action="#null" class="footer-subscribe" onsubmit="return validateNLSubscribe('#txtEmlSub_Footer', '#frmESub_Footer', 'footer');"> <input id="txtEmlSub_Footer" type="text" placeholder="Enter email address..." /> <input type="button" value="Subscribe" onclick="$('#frmESub_Footer').submit(); return false;" /> </form> </div> </div> <div class="col-md-4"> <div class="h4">Most Popular Articles</div> <ul class="articles-list"> <li> <a href="/internet-of-things/industrial-iot-what-it-is-and-the-trends-driving-it-in-2018/" title="Industrial IoT: What It is and the Trends Driving It in 2018 (1167, 1167)">Industrial IoT: What It is and the Trends Driving It in 2018</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/internet-of-things/industrial-iot-what-it-is-and-the-trends-driving-it-in-2018/#disqus_thread'" data-disqus-identifier="c8684ce7d3ed415c9be994cd8f3fab43">view comments</a> </span> </li> <li> <a href="/digital-workplace/a-look-at-the-top-workplace-tools-by-adoption/" title="A Look at the Top Workplace Tools by Adoption (1068, 1068)">A Look at the Top Workplace Tools by Adoption</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/digital-workplace/a-look-at-the-top-workplace-tools-by-adoption/#disqus_thread'" data-disqus-identifier="6d959d7e37eb4e8eb947682d5d85ea7f">view comments</a> </span> </li> <li> <a href="/digital-workplace/the-missing-link-for-digital-transformation-success-people/" title="The Missing Link for Digital Transformation Success? People (835, 835)">The Missing Link for Digital Transformation Success? People</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/digital-workplace/the-missing-link-for-digital-transformation-success-people/#disqus_thread'" data-disqus-identifier="0ddc43b9e2bb4cd08d6b3729b29865ba">view comments</a> </span> </li> <li> <a href="/digital-workplace/what-does-employee-experience-really-mean/" title="What Does Employee Experience Really Mean? (758, 758)">What Does Employee Experience Really Mean?</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/digital-workplace/what-does-employee-experience-really-mean/#disqus_thread'" data-disqus-identifier="89532cd221fb49f6ae24e23c52e32b1b">view comments</a> </span> </li> <li> <a href="/information-management/9-ways-to-jumpstart-your-gdpr-compliance-program/" title="9 Ways to Jumpstart Your GDPR Compliance Program (693, 693)">9 Ways to Jumpstart Your GDPR Compliance Program</a> <span class="comments"> <a class="disqus-comment-count" title="View comments..." onclick="this.href='/information-management/9-ways-to-jumpstart-your-gdpr-compliance-program/#disqus_thread'" data-disqus-identifier="ba6697f4a9074f2c895779b1b71cc668">view comments</a> </span> </li> </ul> </div> <div class="col-md-4"> <div class="h4">Recent Comments</div> <script type="text/javascript" src="https://cmswire.disqus.com/recent_comments_widget.js?num_items=5&amp;amp;hide_avatars=0&amp;amp;avatar_size=24&amp;amp;excerpt_length=150"></script> </div> </div> </div> </div> <div class="final-footer"> <div class="container"> <div class="row"> <div class="col-xs-12 text-center"> <p>&copy; 2018 <a href="http://www.simplermedia.com">Simpler Media Group, Inc</a>. All rights reserved. <br class="visible-sm visible-xs" /> <a href="/about-us/privacy-policy/">Privacy Policy</a>. <a href="http://www.simplermedia.com/mediakit/v1-00/titles/cmswire/legal.php" target="_blank">Terms of Use</a>.</p> <div> Powered by <a href="http://sitecore.net/" target="_blank" rel="nofollow">Sitecore</a> and <a href="http://www.coveo.com/en/solutions/coveo-for-sitecore" target="_blank" rel="nofollow">Coveo</a>.
SMGP v2.1.6604.39727. </div> </div> </div> </div> </div> <div id="div-gpt-ad-1336852434508-6" class=""> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1336852434508-6');
});
} catch (e) {
}; </script> </div> <div id="div-gpt-ad-1352353012906-0" class=""> <script type='text/javascript'> try {
googletag.cmd.push(function () {
googletag.display('div-gpt-ad-1352353012906-0');
});
} catch (e) {
}; </script> </div> </div> <script src="/areas/public/content/js/magnific-popup.js?v=21660439727"></script> <script> (function(d,b,a,s,e){ var t = b.createElement(a), 
     fs = b.getElementsByTagName(a)[0]; t.async=1; t.id=e; t.src=s; 
     fs.parentNode.insertBefore(t, fs); }) 
 (window,document,'script','https://scripts.demandbase.com/f9676d24.min.js','demandbase_js_lib'); </script><script> (function() {
  var didInit = false;
  function initMunchkin() {
    if(didInit === false) {
      didInit = true;
      Munchkin.init('706-YIA-261');
    }
  }
  var s = document.createElement('script');
  s.type = 'text/javascript';
  s.async = true;
  s.src = '//munchkin.marketo.net/munchkin.js';
  s.onreadystatechange = function() {
    if (this.readyState == 'complete' || this.readyState == 'loaded') {
      initMunchkin();
    }
  };
  s.onload = initMunchkin;
  document.getElementsByTagName('head')[0].appendChild(s);
})(); </script><script type="text/javascript">  var disqus_shortname = 'cmswire';

    	(function () {
        	var s = document.createElement('script'); s.async = true;
        	s.type = 'text/javascript';
        	s.src = 'https://' + disqus_shortname + '.disqus.com/count.js';
        	(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
    	
		}()); </script> <script async="async" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=ra-54ecf65f14a7b7c2"></script> <script> var addthis_tw_handle = "CMSWire";
var addthis_tw_author = "";

try { addthis_tw_author = jQuery("meta[name*=creator]").attr("content").replace('@',''); } catch (e) {}
if (addthis_tw_author != '') { addthis_tw_handle = addthis_tw_author; }

var addthis_share = addthis_share || {};
addthis_share = { 
  passthrough : { twitter: {via: addthis_tw_handle, related: 'cmswire,thedxsummit,bdunwood,writenoreen'}}, 
  shorteners : {bitly: {}},
  url_transforms : {
  	add: {
  		utm_source: '{{code}}',
  		utm_medium: 'social',
  		utm_campaign: 'cm',
  		utm_content: 'addthis_share: {{title}}'
  	},
  	shorten: {twitter: 'bitly'}
  }
}; </script> <link rel="stylesheet" type="text/css" href="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.css" /> <script src="//cdnjs.cloudflare.com/ajax/libs/cookieconsent2/3.0.3/cookieconsent.min.js" async="async"></script> <script> window.addEventListener("load", function(){
window.cookieconsent.initialise({
  "palette": {
    "popup": {
      "background": "#252e39"
    },
    "button": {
      "background": "#288fd4"
    }
  },
  "content": {
    "message": "FYI - CMSWire uses cookies, personalization and marketing automation to tailor your experience. ",
    "dismiss": "I understand",
    "href": "https://www.simplermedia.com/policies/privacy-policy/"
  },
  "law": {
      regionalLaw: false,
    },
  "location": true,
})}); </script><script> _linkedin_data_partner_id = "10965"; </script> <script> (function(){var s = document.getElementsByTagName("script")[0];
var b = document.createElement("script");
b.type = "text/javascript";b.async = true;
b.src = "https://snap.licdn.com/li.lms-analytics/insight.min.js";
s.parentNode.insertBefore(b, s);})(); </script> <noscript> <img height="1" width="1" style="display:none;" alt="" src="https://dc.ads.linkedin.com/collect/?pid=10965&fmt=gif" /> </noscript> <script type="text/javascript" src="/public/common/dynamic.js?ids=eaedb9f2-ec27-449b-b2bf-1d7bd824f9bf"></script> </body> </html> 